Bug 1316476 - OData ignores entities with empty list of related entities if $filter is applied to expanded entities
OData ignores entities with empty list of related entities if $filter is appl...
Status: CLOSED CURRENTRELEASE
Product: JBoss Data Virtualization 6
Classification: JBoss
Component: Teiid (Show other bugs)
6.3.0
Unspecified Unspecified
high Severity high
: ER4
: 6.3.0
Assigned To: Van Halbert
Juraj Duráni
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 05:59 EST by Juraj Duráni
Modified: 2016-08-24 07:45 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-08-24 07:45:30 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
JBoss Issue Tracker TEIID-4044 Major Closed OData ignores entities with empty list of related entities if $filter is applied to expanded entities 2016-06-15 08:36 EDT

  None (edit)
Description Juraj Duráni 2016-03-10 05:59:03 EST
Description of problem:
If user want to apply filter for related entities, OData service should return all entities, not only those with non-empty collection of related entities.

*Example:*
*URL:* http://localhost:8080/odata4/olingo_basic/Source/Customers/?$expand=Orders_FK0($filter=place%20eq%20%27town%27)
*Result:* OData returns only 2 customers (both have at least one order with place "town")
*Expectation:* OData should return all 4 customers (two of them should have empty list of orders)
Comment 1 JBoss JIRA Server 2016-03-18 12:01:12 EDT
Ramesh Reddy <rareddy@jboss.org> updated the status of jira TEIID-4044 to Resolved
Comment 2 Van Halbert 2016-03-18 14:19:58 EDT
Duplicate of TEIID-4064

*** This bug has been marked as a duplicate of bug 1316511 ***
Comment 3 JBoss JIRA Server 2016-05-20 09:26:41 EDT
Juraj Duráni <jdurani@redhat.com> updated the status of jira TEIID-4044 to Reopened
Comment 4 Juraj Duráni 2016-05-20 09:27:53 EDT
I have reopened TEIID-4044. This is not resolved in ER3. Note that TEIID-4064 is resolved, but this one not. So I expected this to be no more duplicate of TEIID-4064.
Comment 5 JBoss JIRA Server 2016-05-20 09:41:23 EDT
Juraj Duráni <jdurani@redhat.com> updated the status of jira TEIID-4044 to Closed
Comment 6 JBoss JIRA Server 2016-05-20 09:46:46 EDT
Juraj Duráni <jdurani@redhat.com> updated the status of jira TEIID-4044 to Reopened
Comment 7 JBoss JIRA Server 2016-05-24 07:35:29 EDT
Ramesh Reddy <rareddy@jboss.org> updated the status of jira TEIID-4044 to Resolved
Comment 8 JBoss JIRA Server 2016-06-15 08:36:21 EDT
Steven Hawkins <shawkins@redhat.com> updated the status of jira TEIID-4044 to Closed

Note You need to log in before you can comment on or make changes to this bug.