Bug 1316513 - [RDO Mitaka3 test day] Packstack is not aware of new puppet-keystone changes
[RDO Mitaka3 test day] Packstack is not aware of new puppet-keystone changes
Status: CLOSED WORKSFORME
Product: RDO
Classification: Community
Component: openstack-packstack (Show other bugs)
trunk
Unspecified Unspecified
unspecified Severity unspecified
: ---
: Kilo
Assigned To: Martin Magr
yeylon@redhat.com
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 06:30 EST by Martin Magr
Modified: 2016-04-18 03:02 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-22 05:41:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Martin Magr 2016-03-10 06:30:34 EST
Description of problem:
Applying Puppet manifests                         [ ERROR ]

ERROR : Error appeared during Puppet run: fd00::1b16_keystone.pp
Error: Could not find dependency User[keystone] for Class[Keystone::Cron::Token_flush] at /var/tmp/packstack/78f002ca802343c7a5dcc7899c9fec8f/manifests/fd00::1b16_keystone.pp:36
You will find full trace in log /var/tmp/packstack/20160310-122440-jKTjIu/manifests/fd00::1b16_keystone.pp.log

Version-Release number of selected component (if applicable):
[root@test-controller ~]# rpm -qa openstack*
openstack-puppet-modules-8.0.0a0-0.20160304203011.7dc7e93.el7.centos.noarch
openstack-packstack-puppet-7.0.0-0.12.dev1699.g8f54936.el7.noarch
openstack-packstack-7.0.0-0.12.dev1699.g8f54936.el7.noarch


Additional info:
[root@test-controller ~]# cat /var/tmp/packstack/20160310-122440-jKTjIu/manifests/fd00::1b16_keystone.pp.log
Warning: Scope(Class[Glance::Keystone::Auth]): The public_address parameter is deprecated, use public_url instead.
Warning: Scope(Class[Glance::Keystone::Auth]): The internal_address parameter is deprecated, use internal_url instead.
Warning: Scope(Class[Glance::Keystone::Auth]): The admin_address parameter is deprecated, use admin_url instead.
Warning: Scope(Class[Manila::Keystone::Auth]): The public_address parameter is deprecated, use public_url instead.
Warning: Scope(Class[Manila::Keystone::Auth]): The internal_address parameter is deprecated, use internal_url instead.
Warning: Scope(Class[Manila::Keystone::Auth]): The admin_address parameter is deprecated, use admin_url instead.
Warning: Scope(Class[Ironic::Keystone::Auth]): The public_address parameter is deprecated, use public_url instead.
Warning: Scope(Class[Ironic::Keystone::Auth]): The internal_address parameter is deprecated, use internal_url instead.
Warning: Scope(Class[Ironic::Keystone::Auth]): The admin_address parameter is deprecated, use admin_url instead.
Warning: Scope(Class[Nova::Keystone::Auth]): The public_address parameter is deprecated, use public_url instead.
Warning: Scope(Class[Nova::Keystone::Auth]): The internal_address parameter is deprecated, use internal_url instead.
Warning: Scope(Class[Nova::Keystone::Auth]): The admin_address parameter is deprecated, use admin_url instead.
Warning: Scope(Class[Nova::Keystone::Auth]): Note that service_name parameter default value will be changed to "Compute Service" (according to Keystone default catalog) in a future release. In case you use different value, please update your manifests accordingly.
Warning: Scope(Class[Nova::Keystone::Auth]): Note that service_name_v3 parameter default value will be changed to "Compute Service v3" (according to Keystone default catalog) in a future release. In case you use different value, please update your manifests accordingly.
Warning: Scope(Class[Neutron::Keystone::Auth]): The public_address parameter is deprecated, use public_url instead.
Warning: Scope(Class[Neutron::Keystone::Auth]): The internal_address parameter is deprecated, use internal_url instead.
Warning: Scope(Class[Neutron::Keystone::Auth]): The admin_address parameter is deprecated, use admin_url instead.
Warning: Scope(Class[Swift::Keystone::Auth]): The public_address parameter is deprecated, use public_url and public_url_s3 instead.
Warning: Scope(Class[Ceilometer::Keystone::Auth]): The public_address parameter is deprecated, use public_url instead.
Warning: Scope(Class[Ceilometer::Keystone::Auth]): The internal_address parameter is deprecated, use internal_url instead.
Warning: Scope(Class[Ceilometer::Keystone::Auth]): The admin_address parameter is deprecated, use admin_url instead.
Warning: Scope(Class[Trove::Keystone::Auth]): The public_address parameter is deprecated, use public_url instead.
Warning: Scope(Class[Trove::Keystone::Auth]): The internal_address parameter is deprecated, use internal_url instead.
Warning: Scope(Class[Trove::Keystone::Auth]): The admin_address parameter is deprecated, use admin_url instead.
Notice: Compiled catalog for test-controller.internal in environment production in 3.07 seconds
Warning: The package type's allow_virtual parameter will be changing its default value from false to true in a future release. If you do not want to allow virtual packages, please explicitly set allow_virtual to false.
   (at /usr/share/ruby/vendor_ruby/puppet/type.rb:816:in `set_default')
Error: Could not find dependency User[keystone] for Class[Keystone::Cron::Token_flush] at /var/tmp/packstack/78f002ca802343c7a5dcc7899c9fec8f/manifests/fd00::1b16_keystone.pp:36
[root@test-controller ~]#
Comment 1 Martin Magr 2016-03-22 05:41:22 EDT
Works for me with below version.

openstack-packstack-8.0.0-0.20160321212000.5939a9f.el7.centos.noarch

Note You need to log in before you can comment on or make changes to this bug.