Bug 1316541 - "Visit New File" GTK dialog crashes Emacs when selecting with initial letters
"Visit New File" GTK dialog crashes Emacs when selecting with initial letters
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gtk3 (Show other bugs)
23
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Jan Synacek
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 07:43 EST by Krzysztof Halasa
Modified: 2016-03-21 07:15 EDT (History)
8 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-21 07:15:24 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Krzysztof Halasa 2016-03-10 07:43:47 EST
Description of problem:
Emacs crashes when the user uses "File" -> "Visit New File", types initial letter(s) of the file name, and selects existing file name from the list. Interestingly, it doesn't happen with "File" -> "Open File".

Version-Release number of selected component (if applicable):
emacs-24.5-7.fc23.x86_64

How reproducible:
Always.

Steps to Reproduce:
1. start emacs (with X11 - e.g. "emacs -Q")
2. select from menu: "File" -> "Visit New File"
3. type a letter (used to filter displayed file names)
4. select the file with mouse

Actual results:
Emacs crashes with:
GLib-GIO-Message: Using the 'memory' GSettings backend.  Your settings will not be saved or shared with other applications.

(emacs:8130): Gtk-CRITICAL **: _gtk_file_system_model_get_info: assertion 'GTK_IS_FILE_SYSTEM_MODEL (model)' failed
**
Gtk:ERROR:gtkfilechooserwidget.c:6280:get_display_name_from_file_list: assertion failed: (info != NULL)
Fatal error 6: Aborted
Backtrace:
emacs[0x5062fe]
emacs[0x4ec14e]
emacs[0x50509e]
emacs[0x5052c5]
/lib64/libpthread.so.0(+0x109f0)[0x7fbd1a4149f0]
/lib64/libc.so.6(gsignal+0x38)[0x7fbd19e55a98]
/lib64/libc.so.6(abort+0x16a)[0x7fbd19e5769a]
/lib64/libglib-2.0.so.0(g_assertion_message+0x145)[0x7fbd1e1ee9e5]
/lib64/libglib-2.0.so.0(g_assertion_message_expr+0x4a)[0x7fbd1e1eea7a]
/lib64/libgtk-3.so.0(+0x1b2a9b)[0x7fbd1fce0a9b]
/lib64/libgtk-3.so.0(+0x1a7a03)[0x7fbd1fcd5a03]
/lib64/libgobject-2.0.so.0(g_closure_invoke+0x145)[0x7fbd1e4c77a5]
/lib64/libgobject-2.0.so.0(+0x21851)[0x7fbd1e4d9851]
/lib64/libgobject-2.0.so.0(g_signal_emit_valist+0xe80)[0x7fbd1e4e2530]
/lib64/libgobject-2.0.so.0(g_signal_emit+0x8f)[0x7fbd1e4e28ff]
/lib64/libgobject-2.0.so.0(+0xf9d4)[0x7fbd1e4c79d4]
/lib64/libgobject-2.0.so.0(g_signal_emit_valist+0xc0d)[0x7fbd1e4e22bd]
/lib64/libgobject-2.0.so.0(g_signal_emit+0x8f)[0x7fbd1e4e28ff]
/lib64/libgtk-3.so.0(+0x1207de)[0x7fbd1fc4e7de]
/lib64/libgdk-3.so.0(+0x25658)[0x7fbd1f885658]
/lib64/libglib-2.0.so.0(+0x4a893)[0x7fbd1e1c9893]
/lib64/libglib-2.0.so.0(g_main_context_dispatch+0x15a)[0x7fbd1e1c8e3a]
/lib64/libglib-2.0.so.0(+0x4a1d0)[0x7fbd1e1c91d0]
/lib64/libglib-2.0.so.0(g_main_loop_run+0xc2)[0x7fbd1e1c94f2]
emacs[0x4daf86]
emacs[0x4de477]
emacs[0x4cb637]
emacs[0x56197b]
emacs[0x597df3]
emacs[0x5617cb]
emacs[0x597df3]
emacs[0x5617cb]
emacs[0x597df3]
emacs[0x5617cb]
emacs[0x597df3]
emacs[0x560d0b]
emacs[0x564554]
emacs[0x55d47e]
emacs[0x5619a5]
emacs[0x597df3]
emacs[0x5617cb]
...
Aborted

Expected results:
Emacs should open the file

Additional info:
System is up-to-date Fedora 23.
Comment 1 Jan Synacek 2016-03-15 04:20:42 EDT
I can't reproduce this. Could you please try with Emacs 25?

https://copr.fedorainfracloud.org/coprs/jsynacek/emacs-25/
Comment 2 Krzysztof Halasa 2016-03-21 07:15:24 EDT
The problem still exists with Emacs 25. However, I made another dnf update, and the problem went away (with both Emacs 25 and the mainline 24.5). It is gtk which makes the difference: gtk3-3.18.7-2.fc23.x86_64 crashes Emacs, and the new gtk3-3.18.9-1.fc23.x86_64 does not.

Thanks.

Note You need to log in before you can comment on or make changes to this bug.