Bug 1316597 - [RFE][swift] Add container and account reverse listings
[RFE][swift] Add container and account reverse listings
Status: CLOSED DUPLICATE of bug 1316599
Product: Red Hat OpenStack
Classification: Red Hat
Component: openstack-swift (Show other bugs)
7.0 (Kilo)
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 8.0 (Liberty)
Assigned To: Pete Zaitcev
nlevinki
: FutureFeature
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 09:51 EST by Sean Cohen
Modified: 2016-04-26 11:55 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-22 22:43:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
OpenStack gerrit 120709 None None None 2016-03-10 09:51 EST

  None (edit)
Description Sean Cohen 2016-03-10 09:51:46 EST
This change adds the ability to tell the container or account server to reverse their listings. This is done by sending a reverse=TRUE_VALUE, Where TRUE_VALUE is one of the values true can be in common/utils: TRUE_VALUES = set(('true', '1', 'yes', 'on', 't', 'y')) For example: curl -i -X GET -H "X-Auth-Token: $TOKEN" $STORAGE_URL/c/?reverse=on
Comment 2 Sean Cohen 2016-03-22 22:43:03 EDT

*** This bug has been marked as a duplicate of bug 1316599 ***

Note You need to log in before you can comment on or make changes to this bug.