Bug 1316604 - Update with content hosts no longer in candlepin breaks the migration
Update with content hosts no longer in candlepin breaks the migration
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Candlepin (Show other bugs)
Nightly
Unspecified Unspecified
unspecified Severity unspecified (vote)
: GA
: 6.2
Assigned To: Walden Raines
Katello QA List
http://projects.theforeman.org/issues...
: Triaged
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-10 10:11 EST by Walden Raines
Modified: 2016-07-27 07:03 EDT (History)
4 users (show)

See Also:
Fixed In Version: rubygem-katello-3.0.0.26-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:03:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Foreman Issue Tracker 13856 None None None 2016-04-22 11:53 EDT

  None (edit)
Description Walden Raines 2016-03-10 10:11:25 EST
If you have some hosts no longer in Candlepin and Katello didn't keep track of it, the migration that creates content host facets will fail. Instead, we should avoid creating these facets for hosts whose UUID 404s on Candlepin.
Comment 1 Walden Raines 2016-03-10 10:11:27 EST
Created from redmine issue http://projects.theforeman.org/issues/13856
Comment 2 Walden Raines 2016-03-10 10:11:29 EST
Upstream bug assigned to dlobatog@redhat.com
Comment 4 Bryan Kearney 2016-03-10 12:04:41 EST
Upstream bug component is Candlepin
Comment 5 Walden Raines 2016-03-10 13:09:00 EST
PR - https://github.com/Katello/katello/pull/5867
Comment 6 Bryan Kearney 2016-03-15 12:05:00 EDT
Moving to POST since upstream bug http://projects.theforeman.org/issues/13856 has been closed
-------------
Walden Raines
Applied in changeset commit:katello|6d6ad9287802cfdd0a2dfdc2ae50db96366bb2dd.
Comment 7 Sachin Ghai 2016-06-29 07:10:46 EDT
Hey Walden, Could you please provide steps to verify this bz ?
Comment 8 Walden Raines 2016-06-29 09:42:02 EDT
(In reply to Sachin Ghai from comment #7)
> Hey Walden, Could you please provide steps to verify this bz ?

This is a bad bug report (especially for someone who spent many years as a QA Engineer) and I'd be happy to add some steps to reproduce.   This is an issue we ran into in the wild so I'm not entirely sure how the user got into the state they were in.  

Steps to Reproduce:

1. Find or create a host that only exists in the katello database and not in candlepin. You could maybe do this using SQL.  Either creating a host row manually in the katello datebase or creating a host regularly and then removing it from the candlepin database.
2. Run the migration and not the above failure

I'm sorry these steps to reproduce aren't as precise as either you or I would like but we aren't really sure how the user got into this state.
Comment 9 Bryan Kearney 2016-07-27 07:03:14 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.