Bug 1316710 - `foreman-rake permissions:reset` emits warnings: "circular argument reference - connection" and more
`foreman-rake permissions:reset` emits warnings: "circular argument reference...
Status: CLOSED ERRATA
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Other (Show other bugs)
6.2.0
Unspecified Unspecified
unspecified Severity medium (vote)
: GA
: --
Assigned To: Eric Helms
Katello QA List
: Triaged
Depends On:
Blocks: GSS_Sat6Beta_Tracker/GSS_Sat6_Tracker
  Show dependency treegraph
 
Reported: 2016-03-10 16:14 EST by Jan Hutař
Modified: 2016-07-27 07:51 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-07-27 07:51:13 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jan Hutař 2016-03-10 16:14:49 EST
Description of problem:
`foreman-rake permissions:reset` emits warnings: "circular argument reference - connection" and more


Version-Release number of selected component (if applicable):
Satellite-6.2.0-RHEL-7-20160308.1-Satellite-x86_64


How reproducible:
always


Steps to Reproduce:
1. # foreman-rake permissions:reset


Actual results:
# foreman-rake permissions:reset
/opt/theforeman/tfm/root/usr/share/gems/gems/docker-api-1.17.0/lib/docker.rb:103: warning: circular argument reference - connection
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.6/config/routes/overrides.rb:3: warning: already initialized constant Katello::WhitelistConstraint::PATHS
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.6/config/routes/overrides.rb:3: warning: previous definition of PATHS was here
Reset to user: admin, password: swHsxfeLqABk38cL


Expected results:
No warnings in the output
Comment 1 David Davis 2016-03-17 11:43:15 EDT
Og reported a similar warning message in his /var/log/foreman/cron.log:

/opt/theforeman/tfm/root/usr/share/gems/gems/docker-api-1.17.0/lib/docker.rb:103: warning: circular argument reference - connection

I've this this in development as well. Looks like the fix is here:

https://github.com/swipely/docker-api/commit/7e92801d345e5eaaec4730df7498bc896ee9a070

Which is included in the docker-api gem v1.18.0.
Comment 2 David Davis 2016-03-17 11:48:01 EDT
These are just warnings and not serious errors. So not harmful but it may confuse/mislead users.
Comment 3 Pavel Moravec 2016-04-09 09:16:11 EDT
(In reply to David Davis from comment #1)
> Og reported a similar warning message in his /var/log/foreman/cron.log:
> 
> /opt/theforeman/tfm/root/usr/share/gems/gems/docker-api-1.17.0/lib/docker.rb:
> 103: warning: circular argument reference - connection
> 
> I've this this in development as well. Looks like the fix is here:
> 
> https://github.com/swipely/docker-api/commit/
> 7e92801d345e5eaaec4730df7498bc896ee9a070
> 
> Which is included in the docker-api gem v1.18.0.

Hit it during Sat62 testing days. In my case, I got also mail to /var/spool/mail/root with content:

From root@pmoravec-sat62-rhel7.gsslab.brq.redhat.com  Sat Apr  9 14:53:19 2016
Return-Path: <root@pmoravec-sat62-rhel7.gsslab.brq.redhat.com>
X-Original-To: root
Delivered-To: root@pmoravec-sat62-rhel7.gsslab.brq.redhat.com
Received: by pmoravec-sat62-rhel7.gsslab.brq.redhat.com (Postfix, from userid 0)
	id D3DFC1594F4; Sat,  9 Apr 2016 14:53:19 +0200 (CEST)
From: Anacron <root@pmoravec-sat62-rhel7.gsslab.brq.redhat.com>
To: root@pmoravec-sat62-rhel7.gsslab.brq.redhat.com
Content-Type: text/plain; charset="UTF-8"
Subject: Anacron job 'cron.weekly' on pmoravec-sat62-rhel7.gsslab.brq.redhat.com
Message-Id: <20160409125319.D3DFC1594F4@pmoravec-sat62-rhel7.gsslab.brq.redhat.com>
Date: Sat,  9 Apr 2016 14:53:19 +0200 (CEST)

/etc/cron.weekly/katello-remove-orphans:

/opt/theforeman/tfm/root/usr/share/gems/gems/docker-api-1.17.0/lib/docker.rb:103: warning: circular argument reference - connection
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.15/config/routes/overrides.rb:3: warning: already initialized constant Katello::WhitelistConstraint::PATHS
/opt/theforeman/tfm/root/usr/share/gems/gems/katello-3.0.0.15/config/routes/overrides.rb:3: warning: previous definition of PATHS was here



Any run of /etc/cron.weekly/katello-remove-orphans causes the same, i.e. any customer would be "affected".

Will it be fixed in Sat6.2 GA release or is it worth filing KCS for that until fix released?
Comment 4 David Davis 2016-04-14 08:24:28 EDT
I did a diff between v1.17.0 (the current version in Satellite) and v1.18.0 of the docker-api gem and there's only a few small changes. I don't see any reason why this can't be ready by GA. 

That said, I don't know the criteria for GA bugs at this point though. Paging Mike McCune.
Comment 7 Lukas Pramuk 2016-06-02 11:58:53 EDT
VERIFIED.

@satellite-6.2.0-14.1.el7sat.noarch

# foreman-rake permissions:reset
Reset to user: admin, password: qDLMLXp6RFMaDoYW


>>> no disturbing warnings
Comment 8 Bryan Kearney 2016-07-27 07:51:13 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2016:1501

Note You need to log in before you can comment on or make changes to this bug.