Bug 1316834 - xfce4-clipman-plugin has no icon in the system tray
xfce4-clipman-plugin has no icon in the system tray
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: xfce4-clipman-plugin (Show other bugs)
25
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Mukundan Ragavan
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 04:16 EST by Artem S. Tashkinov
Modified: 2016-12-17 19:06 EST (History)
3 users (show)

See Also:
Fixed In Version: xfce4-clipman-plugin-1.4.1-1.fc25
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-12-12 18:56:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Clipman with icon (65.76 KB, image/png)
2016-09-26 13:58 EDT, Woi
no flags Details
Clipman without icon (59.02 KB, image/png)
2016-09-26 13:59 EDT, Woi
no flags Details
Tray icon of clipman 1.4.1 (1.15 KB, image/png)
2016-12-17 18:56 EST, Woi
no flags Details

  None (edit)
Description Artem S. Tashkinov 2016-03-11 04:16:46 EST
Description of problem: xfce4-clipman-plugin has no icon in the system tray


Version-Release number of selected component (if applicable): 1.2.6-7


How reproducible: always

I would have added a screenshot of nothing but I won't.

According to strace, the only icon xfce4-panel tries to load is:

[pid  6358] open("/home/user/.cache/xfce4/clipman/image0.png", O_RDONLY) = -1 ENOENT (No such file or directory)

Which is obviously wrong.

Of course whenever you copy clipman's icon to this location it shows its icon but that's absolutely wrong as its icon should be fetched from /usr/share/icons
Comment 1 Mukundan Ragavan 2016-03-11 06:07:03 EST
I will take a look. Thanks for the report.
Comment 2 Woi 2016-09-17 15:01:18 EDT
As far as I can tell, there is no clipman icon for fresh installations of Fedora 23 and Fedora 24. Also a system installed as Fedora 23 shows no icon if updated to Fedora 24.
However older installation updated to Fedora 23 or 24 have an icon for clipman.
Comment 3 Woi 2016-09-26 13:58 EDT
Created attachment 1204895 [details]
Clipman with icon

Screenshoot: Clipman with icon
Comment 4 Woi 2016-09-26 13:59 EDT
Created attachment 1204896 [details]
Clipman without icon

Screenshoot: Clipman without icon
Comment 5 Woi 2016-09-26 13:59:40 EDT
I could reproduce this, by switching the icon theme from "Dunst" (clipman has an icon) to "Adwaita" (clipman has no icon). All the others icon themes (Crux, Fedora, GNOME, HighContrast) seem to provide a clipman icon as well.
Comment 6 Artem S. Tashkinov 2016-09-26 14:19:23 EDT
(In reply to Mukundan Ragavan from comment #1)

The look has taken half a year already.

How many more looks do you need to take to resolve this annoying bug?
Comment 7 Woi 2016-09-27 12:57:36 EDT
Update: on a freshly installed Fedora 24, there is no clipman icon, whatever icon theme I choose.

Artem: Please be kind. Mukundan is usually very supportive. But there is lots to do for XFCE on Fedora and not to much volunteers to help. I think he already spends a lots of his spare time for Fedora, while usually getting no more than a "thank you".
If you feel that thinks aren't fixed fast enough, you might ask him how you can support the XFCE spin.
Comment 8 Artem S. Tashkinov 2016-09-27 13:07:39 EDT
(In reply to Woi from comment #7)

Point taken. I apologize for the tone of my message.
Comment 9 Mukundan Ragavan 2016-09-29 22:02:21 EDT
Apologies for the delay Artem and Woi.

I can reproduce this for sure - Adwaita - nothing; menda/faenza icon theme - nice icons present.


But, there seem to be differences - 

I am on Fedora 24 as well and I do see icons with menda/faenza icon themes.

Would there be any interest in testing with the above mentioned icon themes? These are not in Fedora repos but would give us an idea on whether it's really the icon theme or clipman.



Thanks.
Comment 10 Woi 2016-10-16 09:27:56 EDT
Thanks for having a look into this.

I can test this, if it helps. Where did you installed this icons themes from? I'd usually prefer to use a (3rd party) repository or at least a RPM package.
Comment 11 Mukundan Ragavan 2016-10-16 19:57:42 EDT
You can test one or both these themes - 

Menda icon theme (not in repos, I built it)

https://nonamedotclinux.blogspot.com/2016/01/menda-icon-theme.html


Faenza icon theme

http://koji.fedoraproject.org/koji/buildinfo?buildID=460741



Thanks for testing. :)
Comment 12 Woi 2016-10-26 16:51:08 EDT
Hey,

just tested the Menda icon theme: with Menda clipman shows an icon (But it's hard to see if there is some degree of transparency enabled for the panel)
This installation is one of the older ones, which has been updated multiple times.
Comment 13 Mukundan Ragavan 2016-11-27 13:06:48 EST
(In reply to Woi from comment #12)
> Hey,
> 
> just tested the Menda icon theme: with Menda clipman shows an icon (But it's
> hard to see if there is some degree of transparency enabled for the panel)
> This installation is one of the older ones, which has been updated multiple
> times.

OK, this suggests that the issue is possibly an icon theme problem more than anything else. 

One more test please - faenza icon theme has more than one theme - can you try the non-dark theme and see if you can see the icon.

If everything looks ok on other icon themes, perhaps we should think about shipping a symbolic icon or such, I guess.
Comment 14 Mukundan Ragavan 2016-11-28 18:28:17 EST
There is a scratch build for f24 

http://koji.fedoraproject.org/koji/taskinfo?taskID=16661453


and a real build for F25

http://koji.fedoraproject.org/koji/buildinfo?buildID=820957

that will conceivably fix this issue.

Can you please test?
Comment 15 Fedora Update System 2016-11-28 20:47:29 EST
xfce4-clipman-plugin-1.4.1-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0ba46b38c1
Comment 16 Fedora Update System 2016-11-28 21:59:12 EST
xfce4-clipman-plugin-1.4.1-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-0ba46b38c1
Comment 17 Woi 2016-12-02 10:24:56 EST
Thanks for the test build. After installing it on Fedora 24 [1], I have an icon again. However it's not the old icon, but a black white one, which doesn't fit very good to the other icons.


[1] dnf install https://kojipkgs.fedoraproject.org//work/tasks/1455/16661455/xfce4-clipman-plugin-1.4.1-1.fc24.x86_64.rpm
Comment 18 Fedora Update System 2016-12-02 13:55:24 EST
xfce4-clipman-plugin-1.4.1-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-0ba46b38c1
Comment 19 Mukundan Ragavan 2016-12-11 21:22:52 EST
(In reply to Woi from comment #17)
> Thanks for the test build. After installing it on Fedora 24 [1], I have an
> icon again. However it's not the old icon, but a black white one, which
> doesn't fit very good to the other icons.
> 
> 
> [1] dnf install
> https://kojipkgs.fedoraproject.org//work/tasks/1455/16661455/xfce4-clipman-
> plugin-1.4.1-1.fc24.x86_64.rpm

That should probably be the fallback symbolic icon?
Comment 20 Fedora Update System 2016-12-12 18:56:06 EST
xfce4-clipman-plugin-1.4.1-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.
Comment 21 Woi 2016-12-17 18:56 EST
Created attachment 1233009 [details]
Tray icon of clipman 1.4.1
Comment 22 Woi 2016-12-17 19:06:13 EST
Since I'm not sure how the fallback icon looks, I added a screenshot. So please judge your self.
Also the update is missing for Fedora 24:

$sudo dnf list --enablerepo=updates-testing --showduplicates xfce4-clipman-plugin
Last metadata expiration check: 0:13:33 ago on Sun Dec 18 00:51:10 2016.
Installed Packages
xfce4-clipman-plugin.x86_64          1.4.1-1.fc24          @@commandline
Available Packages
xfce4-clipman-plugin.x86_64          1.2.6-8.fc24          fedora       
xfce4-clipman-plugin.x86_64          1.4.1-1.fc24          @@commandline
$

Note You need to log in before you can comment on or make changes to this bug.