Bug 1316836 - Close tab keyboard shortcut does not work if only one tab is open
Close tab keyboard shortcut does not work if only one tab is open
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: xfce4-terminal (Show other bugs)
23
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kevin Fenzi
Fedora Extras Quality Assurance
: Reopened
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-11 04:23 EST by Artem S. Tashkinov
Modified: 2016-03-11 16:43 EST (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-11 13:10:23 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Xfce 12490 None None None 2016-03-11 16:43 EST

  None (edit)
Description Artem S. Tashkinov 2016-03-11 04:23:33 EST
I've got nothing to add.
Comment 1 Mukundan Ragavan 2016-03-11 06:04:40 EST
Yes,

If you have only one tab (or window) open, use the close window shortcut. for xfce4-terminal, that would be CTRL+SHIFT+Q.
Comment 2 Artem S. Tashkinov 2016-03-11 12:44:41 EST
This is a bug since you have to memorize two shortcuts while in most other applications (not limited to Konsole - KDE terminal, Mozilla Firefox, Google Chrome and Internet Explorer) the last tab closes the entire application.

You may close this bug report for as many times as you want while I will reopen it as many times until this bug is resolved.

Logically it makes no sense to have an extra shortcut to close the last open TAB. Yes, it shut downs the whole app but unless you're mentally retarded that's totally expected.
Comment 3 Artem S. Tashkinov 2016-03-11 12:47:43 EST
I'm sorry for being somewhat cocky but I'm filing all these bugs here 'cause upstream is more or less dead (or dormant if you don't like the word "dead"). Perhaps I will write a patch myself but I don't want to get into the innards of GTK coding for the moment. Besides I'm not a programmer.
Comment 4 Kevin Fenzi 2016-03-11 13:10:23 EST
Upstream isn't really dead, Xfce just moves at the pace it does based on people who work on it's spare time. 

This upsteam report is at lease very related: 
https://bugzilla.xfce.org/show_bug.cgi?id=10691

I'd suggest adding your comments there.

I'm sure they would entertain a patch. I don't think we should change behavior of this downstream only. Feel free to re-open, but I don't see us doing anything here until upstream lands a change.
Comment 5 Artem S. Tashkinov 2016-03-11 16:43:20 EST
That bug is very hard to understand and follow - perhaps that's why it has received zero attention. I've filed a new one.

I won't reopen this bug since I have to agree that it makes little sense. A patch from you would be nice though.

Note You need to log in before you can comment on or make changes to this bug.