Bug 131705 - LTC11066-Symbolic link does not exist for hotplugs
Summary: LTC11066-Symbolic link does not exist for hotplugs
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: udev   
(Show other bugs)
Version: 4.0
Hardware: alpha Linux
medium
medium
Target Milestone: ---
: ---
Assignee: Harald Hoyer
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-03 13:22 UTC by Kunal Alva
Modified: 2007-11-30 22:07 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-03 14:12:07 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Kunal Alva 2004-09-03 13:22:51 UTC
From Bugzilla Helper:
User-Agent: Mozilla/4.0 (compatible; MSIE 6.0; Windows NT 5.1; .NET 
CLR 1.1.4322)

Description of problem:
Symbolic links were not created for hotplug events

Note:I am not entitled to raise defects for "Red Hat Enterprise Linux 
Beta", hence opening this bug under product "Red Hat Enterprise Linux 
Beta" 


Version-Release number of selected component (if applicable):
kernel-2.6.7-1.451.2.3, rpm-4.3.2-0.4, RHEL4 Alpha4


How reproducible:
Always

Steps to Reproduce:
1.No symolic link exits for hotplugs
2.
3.
    

Additional info:

Comment 2 Bill Nottingham 2004-09-03 14:54:22 UTC
What sort of symbolic links are you looking for?

What architecture (you mentioned 'alpha', that doesn't seem right. :) )

Comment 3 Kunal Alva 2004-09-06 11:33:56 UTC
Usually for hotplugging support a symbolic link is being created 
which exactly refers to the specific device number of a (e.g.) DASD. 
It means that like in UDEV or DEVFS I have the opportunity to refer 
to a DASD for instance as /udev/dasd/0.0.<devno>/part1. This entry 
infact would be a symbolic link to the original DASD name which might 
be for instance /dev/dasdX1.

My apologies the defect I raised is for Red Hat Enterprise Linux Beta 
Since I do not have the access rights yet, for Red Hat Enterprise 
Linux Beta , I have raised under Red Hat Enterprise Linux.


Comment 6 IBM Bug Proxy 2004-09-30 15:35:22 UTC
----- Additional Comments From mgrf@de.ibm.com  2004-09-30 11:32 EDT -------
ping ? any update here for next beta? 

Comment 7 IBM Bug Proxy 2004-11-16 09:22:12 UTC
----- Additional Comments From kunal.alva@in.ibm.com  2004-11-16 04:20 EDT -------
Hello ! Any info yet on this defect please let us know in case if you require 
any more information.
Thanks
Cheers
Kunal 

Comment 8 IBM Bug Proxy 2004-11-19 09:59:20 UTC
----- Additional Comments From kunal.alva@in.ibm.com  2004-11-19 04:55 EDT -------
I have made the following observations.
When I added two more entries for DASD in the file /etc/udev/rules.d/50-
udev.rules.
KERNEL="dasd*[a-z]", SYMLINK="dasd/%b/disc"
KERNEL="dasd*[0-9]", SYMLINK="dasd/%b/part%n"
The sym links are getting created in the directory /dev/dasd.
However I feel for zSeries these entries should present by default.Please let 
me know your concern on this.
Thanks 

Comment 9 Harald Hoyer 2004-11-19 14:32:10 UTC
are these the only rules you need for udev??

Comment 10 IBM Bug Proxy 2004-11-23 09:08:51 UTC
----- Additional Comments From kunal.alva@in.ibm.com  2004-11-23 04:09 EDT -------
Yes these are the only two entries , which I added to create symbolic links 
for dasd. It works .
Cheers
Kunal 

Comment 11 IBM Bug Proxy 2004-12-28 09:01:35 UTC
----- Additional Comments From kunal.alva@in.ibm.com  2004-12-28 03:57 EDT -------
Tested on pre RC2 release and is not reproducable. This can be closed.
Thanks
Regards
Kunal 

Comment 12 IBM Bug Proxy 2005-01-11 00:27:00 UTC
----- Additional Comments From salina@us.ibm.com  2005-01-10 19:21 EST -------
Closing problem.  Thanks. 


Note You need to log in before you can comment on or make changes to this bug.