Bug 1317142 - Automatic kernel bug reporter doesn't work with the common (and apparently open-source under GPLv2) vboxdrv
Automatic kernel bug reporter doesn't work with the common (and apparently op...
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity high
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-12 08:10 EST by Jonas Thiem
Modified: 2016-03-12 09:18 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-12 09:18:43 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonas Thiem 2016-03-12 08:10:35 EST
Description of problem:
I don't want to get into politics here, I know you have your reasons for not packaging some stuff and leaving it to rpmfusion.

However, it seems really silly that because of a kernel module which 100% of the source is available (correct me on this if I'm wrong!) and which is available under GPLv2 terms even, your bug reporting tool refuses to send bug reports.

I'm running Fedora 23 on a Skylake desktop and laptop and I'm getting A LOT of interesting kernel oopses. Guess what, your sophisticated system doesn't report ANY of them to you because I use the common VirtualBox virtualization solution...

I understand you don't want bugs where VirtualBox is responsible for, but maybe you would want to at least look at some of them seeing if it's actual vboxdrv's fault?


Version-Release number of selected component (if applicable):
4.4.3-300.fc23.x86_64

How reproducible:
100%

Steps to Reproduce:
1. Install vboxdrv from rpmfusion
2. Get a kernel oops

Actual results:
Error reporter refuses because kernel is tainted. It lists "vboxdrv" for which all of the source seems to be available easily, so getting backtraces should be a non-issue..

Expected results:
Error reporting works

Additional info:
Comment 1 Josh Boyer 2016-03-12 09:18:43 EST
Thank you for the report.  We have over 500 bugs reported.  People running tainted kernels can always report bugs manually.  We don't have the time to determine if a bug is a result of something we do not even ship, thus even manual reporters are asked to recreate the issue without any third party modules loaded.  Automated reporting for such setups is simply not desired.

Note You need to log in before you can comment on or make changes to this bug.