Bug 1317179 - kernel-4.4.4-301.fc23.x86_64 causes system to hang on boot
kernel-4.4.4-301.fc23.x86_64 causes system to hang on boot
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
23
x86_64 Linux
unspecified Severity urgent
: ---
: ---
Assigned To: Kernel Maintainer List
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-12 14:32 EST by SP
Modified: 2016-03-23 20:10 EDT (History)
10 users (show)

See Also:
Fixed In Version: kernel-4.4.5-300.fc23.x86_64.rpm kernel-4.4.6-300.fc23
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-23 18:25:58 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screenshot of failed boot (6.01 MB, image/jpeg)
2016-03-12 14:32 EST, SP
no flags Details
Log of failed boot (8.92 KB, text/x-vhdl)
2016-03-14 17:12 EDT, Petr Bartos
no flags Details
Log of failed boot - radeonfix (8.89 KB, text/x-vhdl)
2016-03-15 14:02 EDT, Petr Bartos
no flags Details
Xorg log - radeonfix (2.69 KB, text/plain)
2016-03-15 14:02 EDT, Petr Bartos
no flags Details

  None (edit)
Description SP 2016-03-12 14:32:36 EST
Created attachment 1135664 [details]
screenshot of failed boot

Description of problem: After current fedora updates to kernel-4.4.4-301 the system hangs on boot.  It initially halts on defining drive devices, then progresses a page and fails.  A soft reboot also fails (the system will not reboot.  The only way to get back into the system is to hard boot with the previous kernel (4.4.3-300).  I have checked xfsprogs and it is version 4.3.0-1.fc23.  I had read that earlier versions have a conflict with this kernel.  The problem occurs on both my Dell computers with identical configurations.  The processors are i7-3770 CPU @ 3.40GHz.  The desktop on both is KDE Plasma 5.5.5.


Version-Release number of selected component (if applicable):4.4.4-310


How reproducible:


Steps to Reproduce:
1.Boot with kernel-4.4.4-301
2.System hangs during boot
3. Hard boot into previous kernel required to boot properly.

Actual results: System hangs during boot


Expected results: System should boot normally into desktop GUI


Additional info:
Comment 1 SP 2016-03-12 15:02:04 EST
of interest:
http://jwboyer.livejournal.com/52090.html
Comment 2 stevens.chrisj 2016-03-14 11:56:46 EDT
I have the exact same issue as above and tried the suggested fix found on the page provided by the first commenter to no success.  Boot with an older kernel (4.2.3), and It ill prompt for my encryption passphrase after a few seconds and continue as normal.  With the new one (4.4.4), it hangs at the line "switched to clocksource: tsc".  I have removed all peripherals to no effect.  Any help would be greatly appreciated.  Thanks
Comment 3 SP 2016-03-14 13:05:23 EDT
The links below also reference problems with this kernel - though it seems the culprit may be dracut.  I have tried the solutions offered by users to no avail.  Let us know if it works for you.  Kernel 4.4.5-300  is currently in testing so hopefully that will provide a remedy when a stable version is released.

https://bugzilla.redhat.com/show_bug.cgi?id=1313025

http://forums.fedoraforum.org/showthread.php?t=309076
Comment 4 stevens.chrisj 2016-03-14 15:31:31 EDT
I too had found those posts, but they did not resolve my issue.  Thanks for the reply
Comment 5 Petr Bartos 2016-03-14 16:37:31 EDT
Same problem here (with i686 kernel). I've tried install testing kernel 4.4.5 but problem remains even with this version. Boot hangs with message "A start job is running for Waif for Plymouth Boot Screen to Quit", reboot via ctrl+alt+del hangs on "A stop job is running for The KDE login manager".

However for me it seems like problem with GPU. "journalctl --boot=-1" shows "X server startup timeout, terminating" and /var/log/Xorg.0.log.old ends with "xfree86: Adding drm device /dev/dri/card0" while boot with kernel 4.4.3 Xorg.0.log continues with "xfree86: Adding drm device /dev/dri/card1".

Problem appears only one of my notebooks, Thinkpad T400 with integrated Intel GM45 and discrete AMD RV620. Old atom netbook and new Thinkpad L450 (with integrated Broadwell HD Graphics 5500 and discrete R5 M240) works without problem.
Comment 6 Laura Abbott 2016-03-14 16:47:57 EDT
It sounds like the kernel is booting up but graphics are not starting. Can you switch to a console and collect the journal logs?
Comment 7 Petr Bartos 2016-03-14 17:12 EDT
Created attachment 1136300 [details]
Log of failed boot
Comment 8 Petr Bartos 2016-03-14 17:16:05 EDT
(In reply to Petr Bartos from comment #7)
> Created attachment 1136300 [details]
> Log of failed boot

Unfortunately when boot hangs, it is not possible to switch terminals (last boot message is displayed on all screens). Therefore I guess journalctl --boot=-1 is the only thing I can provide?

BTW I've tried to disable discrete GPU in bios and both 4.4.4 and 4.4.5 kernels are now booting without problems. So it is definitely some problem with radeon driver.
Comment 9 Laura Abbott 2016-03-14 17:50:34 EDT
Okay that's good to know. It will be good to get confirmation from the other reporters to see if it's the same issue for everyone
Comment 10 Laura Abbott 2016-03-14 18:23:55 EDT
http://koji.fedoraproject.org/koji/taskinfo?taskID=13347691 There was a known issue with the radeon driver, can you test this build when it fnishes?
Comment 11 stevens.chrisj 2016-03-15 13:10:43 EDT
I am unfamiliar  with koji but know how to build src.rpms. Could you point me to what I need to do to get the package?  Thank
Comment 12 SP 2016-03-15 13:41:40 EDT
I have a Radeon R9 380 R9 380 4G LE 4GB 256-Bit GDDR5 HDCP Ready CrossFireX Support card so it may be that your kernel package has a problem with Radeon cards.  Let us know when the build is ready for download so we can test it.  Thanks.
Comment 13 Petr Bartos 2016-03-15 14:02 EDT
Created attachment 1136681 [details]
Log of failed boot - radeonfix
Comment 14 Petr Bartos 2016-03-15 14:02 EDT
Created attachment 1136682 [details]
Xorg log - radeonfix
Comment 15 Petr Bartos 2016-03-15 14:04:14 EDT
(In reply to Laura Abbott from comment #10)
> http://koji.fedoraproject.org/koji/taskinfo?taskID=13347691 There was a
> known issue with the radeon driver, can you test this build when it fnishes?

Unfortunately same result with patched kernel
Comment 16 Ricardson Williams 2016-03-15 14:33:12 EDT
I have the same problem also Radeon Graphics(Radeon R7 M260/M265)
Comment 17 SP 2016-03-15 14:36:42 EDT
Well kernel-4.4.5-300.fc23.x86_64.rpm has fixed my problem.  It boots fine with no issues.  I downloaded your rpms from here:
http://koji.fedoraproject.org/koji/buildinfo?buildID=743760
Downloading and installing before the kernel the devel, core, headers, modules and modules-extra packages and last of all the kernel.
Thank you for your work on this Laura Abbott.
Comment 18 SP 2016-03-15 14:42:10 EDT
I see a previous comment was lost.  I also have a Radeon card a Radeon R9 380 4G LE 4GB 256-Bit GDDR5 HDCP Ready CrossFireX Support ATX Video Card to be precise.  So if the problem was with the Radeon card in kernel 4.4.4-301 then 4.4.5-300 resolves it.
Comment 19 Laura Abbott 2016-03-15 14:42:37 EDT
Okay, so it fixed it for one person. Thanks for testing. That fix should be showing up in 4.4.6 which should be coming up for testing tomorrow or Thursday.

There is apparently yet another radeon fix. http://koji.fedoraproject.org/koji/taskinfo?taskID=13356645 is building with just the 2nd fix. Please test that when it finishes if the previous build did not work for you.
Comment 20 cfrancio 2016-03-15 17:59:17 EDT
Same problem here with 4.4.4-301. Update to 4.4.5-300 @updates-testing, works like a charm.
Comment 21 stevens.chrisj 2016-03-16 10:15:14 EDT
The fix worked for me as well.  I am running a Lenovo E460 with a Radeon R7 M360 2GB.  Thanks for the fix Laura!
Comment 22 Petr Bartos 2016-03-16 13:48:14 EDT
(In reply to Laura Abbott from comment #19)
> Okay, so it fixed it for one person. Thanks for testing. That fix should be
> showing up in 4.4.6 which should be coming up for testing tomorrow or
> Thursday.
> 
> There is apparently yet another radeon fix.
> http://koji.fedoraproject.org/koji/taskinfo?taskID=13356645 is building with
> just the 2nd fix. Please test that when it finishes if the previous build
> did not work for you.

Perfect, "radeonfix2" is working. In which kernel version is it expected to be released? In order to know which update to avoid for now. Thanks for fix.
Comment 23 Fedora Update System 2016-03-17 13:51:09 EDT
kernel-4.4.6-300.fc23 has been submitted as an update to Fedora 23. https://bodhi.fedoraproject.org/updates/FEDORA-2016-02ed08bf15
Comment 24 Fedora Update System 2016-03-17 13:52:59 EDT
kernel-4.4.6-200.fc22 has been submitted as an update to Fedora 22. https://bodhi.fedoraproject.org/updates/FEDORA-2016-3a57b19360
Comment 25 Ricardson Williams 2016-03-17 20:07:08 EDT
(In reply to SP from comment #17)
> Well kernel-4.4.5-300.fc23.x86_64.rpm has fixed my problem.  It boots fine
> with no issues.  I downloaded your rpms from here:
> http://koji.fedoraproject.org/koji/buildinfo?buildID=743760
> Downloading and installing before the kernel the devel, core, headers,
> modules and modules-extra packages and last of all the kernel.
> Thank you for your work on this Laura Abbott.

Works well.
Comment 26 Fedora Update System 2016-03-18 19:55:01 EDT
kernel-4.4.6-200.fc22 has been pushed to the Fedora 22 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-3a57b19360
Comment 27 Fedora Update System 2016-03-18 21:24:46 EDT
kernel-4.4.6-300.fc23 has been pushed to the Fedora 23 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-02ed08bf15
Comment 28 SP 2016-03-20 12:42:13 EDT
kernel-4.4.6-300.fc23 works well for me (R9 380).  No problems that I can find.  Thank you.
Comment 29 Petr Bartos 2016-03-21 05:47:34 EDT
With 4.4.6 on Thinkpad L450 (integrated Broadwell HD Graphics 5500, discrete R5 M240 - the one which was working without problems with 4.4.4 and 4.4.5) I'm encountering strange "micro freezes", typically when opening new window (including tooltips) or changing resolution (in Plasma 5). Desktop is completely frozen from few seconds up to one minute and then works without problems. Freezes seems to be random (not triggered with each desktop windows change). Dmesg contains following:

[ 5835.806107] [drm] probing gen 2 caps for device 8086:9c98 = 5323c42/0
[ 5835.806112] [drm] PCIE gen 2 link speeds already enabled
[ 5835.812181] [drm] PCIE GART of 2048M enabled (table at 0x0000000000040000).
[ 5835.812282] radeon 0000:05:00.0: WB enabled
[ 5835.812285] radeon 0000:05:00.0: fence driver on ring 0 use gpu addr 0x0000000080000c00 and cpu addr 0xffff8802501b5c00
[ 5835.812286] radeon 0000:05:00.0: fence driver on ring 1 use gpu addr 0x0000000080000c04 and cpu addr 0xffff8802501b5c04
[ 5835.812287] radeon 0000:05:00.0: fence driver on ring 2 use gpu addr 0x0000000080000c08 and cpu addr 0xffff8802501b5c08
[ 5835.812288] radeon 0000:05:00.0: fence driver on ring 3 use gpu addr 0x0000000080000c0c and cpu addr 0xffff8802501b5c0c
[ 5835.812289] radeon 0000:05:00.0: fence driver on ring 4 use gpu addr 0x0000000080000c10 and cpu addr 0xffff8802501b5c10
[ 5835.812291] radeon 0000:05:00.0: VCE init error (-22).
[ 5836.004058] [drm] ring test on 0 succeeded in 1 usecs
[ 5836.004063] [drm] ring test on 1 succeeded in 1 usecs
[ 5836.004069] [drm] ring test on 2 succeeded in 1 usecs
[ 5836.004077] [drm] ring test on 3 succeeded in 4 usecs
[ 5836.004084] [drm] ring test on 4 succeeded in 4 usecs
[ 5836.004133] [drm] ib test on ring 0 succeeded in 0 usecs
[ 5836.004165] [drm] ib test on ring 1 succeeded in 0 usecs
[ 5836.004191] [drm] ib test on ring 2 succeeded in 0 usecs
[ 5836.004204] [drm] ib test on ring 3 succeeded in 0 usecs
[ 5836.004216] [drm] ib test on ring 4 succeeded in 0 usecs
[ 5838.785655] usb 2-6.1: reset full-speed USB device number 4 using xhci_hcd
[ 5839.442236] xhci_hcd 0000:00:14.0: WARN Event TRB for slot 3 ep 4 with no TDs queued?
[ 5840.725489] xhci_hcd 0000:00:14.0: WARN Event TRB for slot 3 ep 4 with no TDs queued?
[ 5889.695397] [drm] probing gen 2 caps for device 8086:9c98 = 5323c42/0
[ 5889.695402] [drm] PCIE gen 2 link speeds already enabled
[ 5889.701521] [drm] PCIE GART of 2048M enabled (table at 0x0000000000040000).
[ 5889.701628] radeon 0000:05:00.0: WB enabled
[ 5889.701630] radeon 0000:05:00.0: fence driver on ring 0 use gpu addr 0x0000000080000c00 and cpu addr 0xffff8802501b5c00
[ 5889.701631] radeon 0000:05:00.0: fence driver on ring 1 use gpu addr 0x0000000080000c04 and cpu addr 0xffff8802501b5c04
[ 5889.701633] radeon 0000:05:00.0: fence driver on ring 2 use gpu addr 0x0000000080000c08 and cpu addr 0xffff8802501b5c08
[ 5889.701634] radeon 0000:05:00.0: fence driver on ring 3 use gpu addr 0x0000000080000c0c and cpu addr 0xffff8802501b5c0c
[ 5889.701635] radeon 0000:05:00.0: fence driver on ring 4 use gpu addr 0x0000000080000c10 and cpu addr 0xffff8802501b5c10
[ 5889.701636] radeon 0000:05:00.0: VCE init error (-22).
[ 5889.894938] [drm] ring test on 0 succeeded in 1 usecs
[ 5889.894943] [drm] ring test on 1 succeeded in 1 usecs
[ 5889.894948] [drm] ring test on 2 succeeded in 1 usecs
[ 5889.894956] [drm] ring test on 3 succeeded in 4 usecs
[ 5889.894963] [drm] ring test on 4 succeeded in 4 usecs
[ 5889.895057] [drm] ib test on ring 0 succeeded in 0 usecs
[ 5889.895095] [drm] ib test on ring 1 succeeded in 0 usecs
[ 5889.895167] [drm] ib test on ring 2 succeeded in 0 usecs
[ 5889.895200] [drm] ib test on ring 3 succeeded in 0 usecs
[ 5889.895212] [drm] ib test on ring 4 succeeded in 0 usecs
Comment 30 Petr Bartos 2016-03-21 08:49:19 EDT
Sorry, it was not problem of this kernel, I ran into this issue https://bugzilla.redhat.com/show_bug.cgi?id=1317145
Comment 31 Fedora Update System 2016-03-23 18:24:43 EDT
kernel-4.4.6-300.fc23 has been pushed to the Fedora 23 stable repository. If problems still persist, please make note of it in this bug report.
Comment 32 Fedora Update System 2016-03-23 19:58:57 EDT
kernel-4.4.6-200.fc22 has been pushed to the Fedora 22 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.