Bug 1317212 - please re-enable ReplayGain plugin
please re-enable ReplayGain plugin
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: beets (Show other bugs)
24
All Linux
unspecified Severity low
: ---
: ---
Assigned To: Michele Baldessari
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-12 19:23 EST by smitna
Modified: 2016-03-26 14:08 EDT (History)
1 user (show)

See Also:
Fixed In Version: beets-1.3.17-4.fc24
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-26 14:08:32 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
patch to spec file (1.43 KB, patch)
2016-03-12 19:23 EST, smitna
no flags Details | Diff

  None (edit)
Description smitna 2016-03-12 19:23:35 EST
Created attachment 1135758 [details]
patch to spec file

Description of problem:
Plugin "replaygain" is actually generated upon build but removed upon install.  A comment in the spec file provides a rationale:

# **** Disabled plugins ****
# due to missing dependencies or dependencies being in rpmfusion
...
# replaygain --> mp3gain (rpmfusion only)

However, mp3gain is not a strict dependency of this plugin but merely a particular backend option.  A functional GStreamer 1.0 backend is also supported, and all of its dependencies are available in official Fedora repositories, so there is no need to disable this plugin.


Version-Release number of selected component (if applicable):
1.3.17-1.fc24
(see:  http://koji.fedoraproject.org/koji/buildinfo?buildID=734412)

Additional info:
Attached is a patch to the RPM spec file.  It successfully builds SRPM and RPMs (via mock) in Fedora 23, and I have confirmed that the replaygain feature is functional when configured according to official docs:

http://beets.readthedocs.org/en/v1.3.17/plugins/replaygain.html#gstreamer
Comment 1 Fedora Update System 2016-03-14 13:43:13 EDT
beets-1.3.17-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-408bff7815
Comment 2 Fedora Update System 2016-03-15 17:31:24 EDT
beets-1.3.17-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-408bff7815
Comment 3 Fedora Update System 2016-03-26 14:08:30 EDT
beets-1.3.17-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.