This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 1317237 - root output in terminal is too long
root output in terminal is too long
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: bash (Show other bugs)
23
x86_64 Linux
unspecified Severity low
: ---
: ---
Assigned To: David Kaspar [Dee'Kej]
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-13 05:16 EDT by aurelien
Modified: 2016-03-14 05:17 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-14 05:17:15 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description aurelien 2016-03-13 05:16:39 EDT
Description of problem:
the user output is: aurelien@bigfoot:~$
the root output is: aurelien@bigfoot:/home/aurelien[root@bigfoot aurelien]#

That is on xterm and gnome terminal using bash


Version-Release number of selected component (if applicable):


How reproducible: su on fedora 23 workstation


Steps to Reproduce:
1. su
2.
3.

Actual results:
aurelien@bigfoot:/home/aurelien[root@bigfoot aurelien]# 

Expected results:
[root@bigfoot aurelien]#
or just
root@bigfoot:/# 

Additional info:
just that it get lots of space in the output
Comment 1 Mattias Ellert 2016-03-14 04:31:46 EDT
Hi!

I think you have reported this issue to the wrong package. The root package is not responsible for setting the shell prompt when logging in as the root user.

The root package is the numerical analysis framework developed at CERN: http://root.cern.ch

I reassign this to bash since this is my best guess. If this is not correct, please hand it over to whoever you think is responsible.
Comment 2 Kamil Dudka 2016-03-14 05:10:26 EDT
This does not look like the default configuration of bash.  Please provide the output of the following command:

# echo $SHELL $PS1 $PROMPT_COMMAND
Comment 3 aurelien 2016-03-14 05:17:15 EDT
Got it!
Thanks ... it comes from a mix of I made in the .bashrc years after years!
sorry for the disturb

Note You need to log in before you can comment on or make changes to this bug.