Bug 1317297 - Zanata doesn't allow message translation of anaconda
Zanata doesn't allow message translation of anaconda
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
rawhide
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Brian Lane
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-13 16:51 EDT by Göran Uddeborg
Modified: 2016-06-17 18:12 EDT (History)
5 users (show)

See Also:
Fixed In Version: anaconda-25.18-1
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-06-17 18:12:59 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Göran Uddeborg 2016-03-13 16:51:56 EDT
Description of problem:
There are three messages in the current anaconda po file where the enter key is marked with the syntax <Enter>.  When translating this, Zanata assumes that the key name is markup, and refuses the translated message.  These messages needs to be marked in some way to tell Zanata that they do not contain markup.  I don't know if there is such a feature currently; if not that would be a feature request with Zanata I guess.

A workaround would of course be to use some other kind of quotes to mark the key name.

The affected messages are

"Please press <Enter> to get a shell. "
"Enter a new value for '%s' and press <Enter>\n"
"Press <Enter> to reboot your system.\n"
Comment 1 Brian Lane 2016-03-14 20:15:47 EDT
Have you tried contacting Zanata to see if they have any suggestions? I suppose that [Enter] would be just as clear -- assuming Zanata allows that :)
Comment 2 Göran Uddeborg 2016-03-15 05:23:55 EDT
Reporting to Zanata was actually my first reaction (https://lists.fedoraproject.org/archives/list/trans@lists.fedoraproject.org/thread/IC2CA5G5VEIH3KXRKN3IUZILBKJZMBUQ/).  But in the replies on the mailing list that idea was questioned.

As I understand it, someone from the development team has asked for XML validation of messages.  And in the majority of cases, that is probably a good thing.  So the right action seems to be for you to somehow mark these messages. To tell Zanata that in these particular cases, it should not do any XML validation.

Or to take the easy way out and use [Enter] instead. :-)
Comment 3 Brian Lane 2016-03-16 19:24:48 EDT
https://github.com/rhinstaller/anaconda/pull/558
Comment 4 Mike McCune 2016-03-28 18:19:01 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions

Note You need to log in before you can comment on or make changes to this bug.