Bug 1317299 - SELinux is preventing systemd-logind from 'getattr' accesses on the file /dev/shm/lldpad.state.
SELinux is preventing systemd-logind from 'getattr' accesses on the file /dev...
Status: CLOSED DUPLICATE of bug 1284293
Product: Fedora
Classification: Fedora
Component: selinux-policy (Show other bugs)
24
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Miroslav Grepl
Fedora Extras Quality Assurance
abrt_hash:06792b7dfe1e4a2cbe2df373025...
:
: 1359320 1370529 1379119 1380914 1403446 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-13 17:29 EDT by Joachim Frieben
Modified: 2016-12-10 06:45 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-03-15 12:46:34 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Joachim Frieben 2016-03-13 17:29:37 EDT
Description of problem:
SELinux is preventing systemd-logind from 'getattr' accesses on the file /dev/shm/lldpad.state.

*****  Plugin restorecon (99.5 confidence) suggests   ************************

If you want to fix the label. 
/dev/shm/lldpad.state default label should be lldpad_tmpfs_t.
Then you can run restorecon.
Do
# /sbin/restorecon -v /dev/shm/lldpad.state

*****  Plugin catchall (1.49 confidence) suggests   **************************

If you believe that systemd-logind should be allowed getattr access on the lldpad.state file by default.
Then you should report this as a bug.
You can generate a local policy module to allow this access.
Do
allow this access for now by executing:
# grep systemd-logind /var/log/audit/audit.log | audit2allow -M mypol
# semodule -i mypol.pp

Additional Information:
Source Context                system_u:system_r:systemd_logind_t:s0
Target Context                system_u:object_r:tmpfs_t:s0
Target Objects                /dev/shm/lldpad.state [ file ]
Source                        systemd-logind
Source Path                   systemd-logind
Port                          <Unknown>
Host                          (removed)
Source RPM Packages           
Target RPM Packages           
Policy RPM                    selinux-policy-3.13.1-178.fc24.noarch
Selinux Enabled               True
Policy Type                   targeted
Enforcing Mode                Enforcing
Host Name                     (removed)
Platform                      Linux (removed) 4.5.0-0.rc7.git0.2.fc24.x86_64 #1
                              SMP Tue Mar 8 02:20:08 UTC 2016 x86_64 x86_64
Alert Count                   1
First Seen                    2016-03-13 22:18:08 CET
Last Seen                     2016-03-13 22:18:08 CET
Local ID                      4c90d307-d53d-4683-aee7-1ca9339ff45b

Raw Audit Messages
type=AVC msg=audit(1457903888.976:485): avc:  denied  { getattr } for  pid=864 comm="systemd-logind" path="/dev/shm/lldpad.state" dev="tmpfs" ino=12772 scontext=system_u:system_r:systemd_logind_t:s0 tcontext=system_u:object_r:tmpfs_t:s0 tclass=file permissive=0


Hash: systemd-logind,systemd_logind_t,tmpfs_t,file,getattr

Version-Release number of selected component:
selinux-policy-3.13.1-178.fc24.noarch

Additional info:
reporter:       libreport-2.6.4
hashmarkername: setroubleshoot
kernel:         4.5.0-0.rc7.git0.2.fc24.x86_64
type:           libreport

Potential duplicate: bug 1190461
Comment 1 Lukas Vrabec 2016-03-15 12:46:34 EDT

*** This bug has been marked as a duplicate of bug 1284293 ***
Comment 2 Kirill Berezin 2016-07-22 16:09:54 EDT
*** Bug 1359320 has been marked as a duplicate of this bug. ***
Comment 3 Dave Allan 2016-08-26 10:50:51 EDT
*** Bug 1370529 has been marked as a duplicate of this bug. ***
Comment 4 Dmitrtiy 2016-09-25 03:09:19 EDT
*** Bug 1379119 has been marked as a duplicate of this bug. ***
Comment 5 Dmitrtiy 2016-10-01 08:54:46 EDT
*** Bug 1380914 has been marked as a duplicate of this bug. ***
Comment 6 Dmitrtiy 2016-12-10 06:45:06 EST
*** Bug 1403446 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.