Bug 1317325 - Puppet keeps logging "sh: vdsmdummy: command not found" when ifconfig ';vdsmdummy;'
Puppet keeps logging "sh: vdsmdummy: command not found" when ifconfig ';vdsmd...
Status: CLOSED NEXTRELEASE
Product: Red Hat Satellite 6
Classification: Red Hat
Component: Fact (Show other bugs)
6.1.7
Unspecified Unspecified
high Severity medium (vote)
: Unspecified
: --
Assigned To: satellite6-bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2016-03-13 20:58 EDT by Shinobu KINJO
Modified: 2016-05-11 14:28 EDT (History)
3 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2016-04-22 17:05:12 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Shinobu KINJO 2016-03-13 20:58:21 EDT
# Description of problem:
######

When we do:

 ~$ ifconfig ';vdsmdummy;'

the puppet logs:

 sh: vdsmdummy: command not found


Probably it's good enough to enclose #{interface} in single quotes in ip.rb located at "lib/facter/util".

Only this line:

 lib/facter/util/ip.rb#130
 output = Facter::Util::IP.exec_ifconfig([interface,"2>/dev/null"])

is a bit different.
interface becomes #{interface} then will be transformed to "'#{interface}'".

AFAIK: it's fixed in ★facter-2.4.3-3.el7★ but ★facter-1.7.6-2.el6sat★ -;
Please do very small change...

# Version-Release number of selected component (if applicable):
######

Name        : facter
Arch        : x86_64
Epoch       : 1
Version     : 1.7.6
Release     : 2.el6sat
Size        : 238 k
Repo        : installed
From repo   : rhel-6-server-satellite-6.1-rpms
Summary     : Ruby module for collecting simple facts about a host operating system
URL         : http://www.puppetlabs.com/puppet/related-projects/facter
License     : ASL 2.0
Description : Ruby module for collecting simple facts about a host Operating
            : system. Some of the facts are preconfigured, such as the hostname and the
            : operating system. Additional facts can be added through simple Ruby scripts

# How reproducible:
######

# Steps to Reproduce:
######
1.
2.
3.

# Actual results:
######

# Expected results:
######

# Additional info:
######
Comment 1 Bryan Kearney 2016-04-22 17:05:12 EDT
Satellite 6.2 will be delivering facter 2.4.6. I am closing this out as NEXT_RELEASE since we will not be backporting changes to facter.

Note You need to log in before you can comment on or make changes to this bug.