Bug 1317367 - Respin of 7.2.3 rhel-tools-docker [NEEDINFO]
Respin of 7.2.3 rhel-tools-docker
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 7
Classification: Red Hat
Component: rhel-tools-docker (Show other bugs)
7.2
Unspecified Unspecified
unspecified Severity unspecified
: rc
: ---
Assigned To: Eliska Slobodova
atomic-bugs@redhat.com
Vikram Goyal
:
Depends On:
Blocks: 1357094
  Show dependency treegraph
 
Reported: 2016-03-14 02:41 EDT by Frantisek Kluknavsky
Modified: 2016-07-15 13:25 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1313030
: 1357094 (view as bug list)
Environment:
Last Closed: 2016-03-31 19:26:54 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
ajia: needinfo? (walters)


Attachments (Terms of Use)

  None (edit)
Description Frantisek Kluknavsky 2016-03-14 02:41:34 EDT
Tracking the respin of rhel-tools-docker
Comment 6 Daniel Walsh 2016-03-22 11:42:47 EDT
Looks like you are trying to install an rpm package onto an atomic host?
Comment 7 Colin Walters 2016-03-22 11:50:40 EDT
This is an incompatiblity with atomic-pkglayer and the docker `%post` - it's unaware that we're running inside a container.

https://github.com/GNOME/ostree/pull/212

will address this by allowing use of `rpm -Uvh docker.rpm` outside of a container.
Comment 8 Colin Walters 2016-03-22 11:52:16 EDT
Currently though in order to test the new Docker you'd need an updated tree.

We can probably fix this in docker though by having its %post detect if it's inside a container and not try to load the policy?  Something like `if test ${container} = "docker"` ?
Comment 9 Daniel Walsh 2016-03-22 11:54:43 EDT
It is actually blowing up when trying to compile policy.
Comment 10 Alex Jia 2016-03-22 12:05:40 EDT
(In reply to Daniel Walsh from comment #6)
> Looks like you are trying to install an rpm package onto an atomic host?

Yes, using atomic-pkglayer to update docker RPM pacakges onto an      Atomic Host.
Comment 11 Alex Jia 2016-03-24 05:06:22 EDT
(In reply to Colin Walters from comment #8)
> We can probably fix this in docker though by having its %post detect if it's
> inside a container and not try to load the policy?  Something like `if test
> ${container} = "docker"` ?

Colin, do we plan to fix this on 7.2.4? if so, I will close the bug as VERIFIED, because except this failure, the atomic-pkglayer works well.
Comment 13 errata-xmlrpc 2016-03-31 19:26:54 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://rhn.redhat.com/errata/RHBA-2016-0578.html

Note You need to log in before you can comment on or make changes to this bug.