Bug 131771 - undefined code
undefined code
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mx (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mihai Ibanescu
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-04 03:11 EDT by d.binderman
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version: mx-2.0.6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-09-30 15:49:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description d.binderman 2004-09-04 03:11:40 EDT
Description of problem:

I just tried to compile package mx-2.0.5-3 from
Redhat Fedora Core 3 Test 1.

The compiler said


mx/Stack/mxStack/mxStack.c:297: warning: operation on `top' may be
undefined

The source code is

				Py_DECREF(stack->array[top--]);

This code is undefined. Suggest

				Py_DECREF(stack->array[ top]);
				--top;



Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.
  
Actual results:


Expected results:


Additional info:
Comment 1 Mihai Ibanescu 2004-10-07 01:25:44 EDT
Hmm. There are lots of warnings about pointers being "abused".

CFLAGS="-Wall" python setup.py build

See also bug 116880 - probably related to the unsafe pointer manipulation.
Comment 2 Mihai Ibanescu 2005-09-30 15:49:16 EDT
This seems to be fixed in 2.0.6

Note You need to log in before you can comment on or make changes to this bug.