Bug 131831 - Adds already installed packages with same version-release for update
Adds already installed packages with same version-release for update
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
3
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-05 09:15 EDT by Bob Cochran
Modified: 2014-01-21 17:49 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-15 18:56:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Output of yum -d 5 obsoletes update (10.61 KB, text/plain)
2004-09-05 09:18 EDT, Bob Cochran
no flags Details

  None (edit)
Description Bob Cochran 2004-09-05 09:15:38 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
When running 'yum --obsoletes update' the update adds an already
installed package, katana-1.0.4-4, to the list of packages for update
and then aborts on a transaction check error. I'll attach the output
of 'yum -d 5 --obsoletes update' below.

Version-Release number of selected component (if applicable):
2.1.3-1

How reproducible:
Always

Steps to Reproduce:
1. yum --obsoletes update
2.
3.
    

Actual Results:  Update ended on a Transaction Check Error because one
package was already installed.

Expected Results:  yum should not have selected an already installed
package, of the same version and release, for update.

Additional info:
Comment 1 Bob Cochran 2004-09-05 09:18:15 EDT
Created attachment 103481 [details]
Output of yum -d 5 obsoletes update
Comment 2 Seth Vidal 2004-09-15 18:56:16 EDT
Fixed in CVS - upstream

Note You need to log in before you can comment on or make changes to this bug.