Bug 131869 - /etc/sysctl.conf overwritten and not backed up when initscripts rpm updated
/etc/sysctl.conf overwritten and not backed up when initscripts rpm updated
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 2.1
Classification: Red Hat
Component: initscripts (Show other bugs)
2.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-06 00:25 EDT by David Gillies
Modified: 2014-03-16 22:47 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-08 11:05:00 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Gillies 2004-09-06 00:25:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040808 Firefox/0.9.3

Description of problem:


Version-Release number of selected component (if applicable):
initscripts-6.47.8-1

How reproducible:
Always

Steps to Reproduce:
1. make changes to /etc/sysctl.conf
2. rpm -Uvh initscripts*.rpm
3. check /etc/sysctl.conf for previous changes (there should be none)
4. check for any sysctl.conf.rpmsave or sysctl.conf.rpmnew. there
won't be any
    

Actual Results:  /etc/sysctl.conf was overwritten with the packaged
version

Expected Results:  /etc/sysctl.conf should have either been backed up
to sysctl.conf.rpmsave or the packaged version should have been
written to sysctl.conf.rpmnew

Additional info:
Comment 1 Bill Nottingham 2004-09-06 17:07:15 EDT
%config(noreplace) /etc/sysctl.conf

It's already marked as such. Can you reproduce this at will?
Comment 2 Suzanne Hillman 2005-04-08 11:05:00 EDT
Due to no reply to the question in comment #1 in many months, closing.

Note You need to log in before you can comment on or make changes to this bug.