Bug 131878 - iostat leaks file handles
iostat leaks file handles
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: sysstat (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Charlie Bennett
Brian Brock
:
: 133466 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-06 05:25 EDT by Pasi Pirhonen
Modified: 2007-11-30 17:07 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-13 16:14:50 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Pasi Pirhonen 2004-09-06 05:25:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.6)
Gecko/20040123 Debian/1.6-1.he-1

Description of problem:
iostat leaks on handle for every polling cycle

iostat    30189    root    3r   REG        0,2        0       4101
/proc/stat
iostat    30189    root    4r   REG        0,2        0       4101
/proc/stat
iostat    30189    root    5r   REG        0,2        0       4101
/proc/stat


Until it dies for 'too many open files' or what ever that is.
For 5 secs update cycle it's 85mins.



Version-Release number of selected component (if applicable):
sysstat-4.0.7-4.EL3.3

How reproducible:
Always

Steps to Reproduce:
1. run iostat and it's blow eventually
2.
3.
    

Actual Results:  runs out of filehandles


Expected Results:  iostat should run forever

Additional info:
Comment 1 Charlie Bennett 2004-09-07 11:08:37 EDT
Hi - which arguments to iostat are you using?

Thanks
Comment 2 Pasi Pirhonen 2004-09-07 11:54:21 EDT
iostat -x sda4 -d 5

and for every 'screen update' it leaks one /proc/stat handle until
it's runs out in about 85mins
Comment 3 Charlie Bennett 2004-09-08 13:07:00 EDT
Hi - I'm testing sysstat 5.0.5 for inclusion in the next update.  I
managed to run iostat -x sda2 -d 1 overnight without running out of
file handles using this version.  

If you are so inclined, check out the unsupported builds of this
version at http://people.redhat.com/ccb/sysstat and let me know what
you think.
Comment 4 Pasi Pirhonen 2004-09-08 13:22:46 EDT
lsof | grep iostat
iostat    1719    root  cwd    DIR        8,2      4096         2 /
iostat    1719    root  rtd    DIR        8,2      4096         2 /
iostat    1719    root  txt    REG        8,2     20300    918645
/usr/bin/iostat
iostat    1719    root  mem    REG        8,2    106888    523272
/lib/ld-2.3.2.so
iostat    1719    root  mem    REG        8,2   1568876   1308187
/lib/tls/libc-2.3.2.so
iostat    1719    root  mem    REG        8,2  32148976    703170
/usr/lib/locale/locale-archive
iostat    1719    root    0u   CHR      136,4                   6
/dev/pts/4
iostat    1719    root    1u   CHR      136,4                   6
/dev/pts/4
iostat    1719    root    2u   CHR      136,4                   6
/dev/pts/4


After 10 or so minutes, so it's NOT leaking file handles anymore

command again 'iostat -x sda4 -d 5'


Will you close this with proper status? 
Comment 5 Göran Uddeborg 2004-09-24 08:14:14 EDT
*** Bug 133466 has been marked as a duplicate of this bug. ***
Comment 6 Charlie Bennett 2004-09-29 17:27:24 EDT
Fixed by errata candidate RHBA-2004:506
Comment 8 John Flanagan 2004-12-13 16:14:50 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-503.html
Comment 9 John Flanagan 2004-12-20 23:01:03 EST
An advisory has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-506.html

Note You need to log in before you can comment on or make changes to this bug.