Bug 131902 - Rescue mode fails with File Exists error
Rescue mode fails with File Exists error
Status: CLOSED DUPLICATE of bug 127530
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity high
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-06 11:13 EDT by Bevis King
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:29 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bevis King 2004-09-06 11:13:30 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20040319 Galeon/1.3.7

Description of problem:
The Fedora Core 3 test 1 anaconda aborts with a python error traceback
when trying to boot in rescue mode on a reasonably intact system.

The messages are:
[....]
Running anaconda, the Fedora Core rescure mode - please wait
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 592, in ?
    rescue.runRescue(rootPath, not rescue_nomount, id)
  File "/usr/lib/anaconda/rescue.py", line 167, in runRescue
    os.symlink('/mnt/runtime/etc' + file, '/etc/' + file )
OSError: [Errno 17] File Exists
install exited abnormally
[....]


Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.  Boot from CD-ROM in rescue mode:  "linux rescue"
2.
3.
    

Actual Results:  [....]
Running anaconda, the Fedora Core rescure mode - please wait
Traceback (most recent call last):
  File "/usr/bin/anaconda", line 592, in ?
    rescue.runRescue(rootPath, not rescue_nomount, id)
  File "/usr/lib/anaconda/rescue.py", line 167, in runRescue
    os.symlink('/mnt/runtime/etc' + file, '/etc/' + file )
OSError: [Errno 17] File Exists
install exited abnormally
[....]

Expected Results:  A shell prompt to perform rescue from....

Additional info:
Comment 1 Jeremy Katz 2004-09-07 00:36:24 EDT

*** This bug has been marked as a duplicate of 127530 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:29 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.