Bug 131920 - .xsession-errors: Invalid entry (missing ']') at /usr/bin/pam-panel-icon:1
.xsession-errors: Invalid entry (missing ']') at /usr/bin/pam-panel-icon:1
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: kdeadmin (Show other bugs)
1
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Ngo Than
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-06 16:23 EDT by Sergio Monteiro Basto
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-02-08 19:38:19 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
.xsession-errors on new user (2.70 KB, text/plain)
2004-12-13 15:21 EST, Sergio Monteiro Basto
no flags Details
where is Portuguese flag ? (246.48 KB, image/png)
2004-12-13 17:57 EST, Sergio Monteiro Basto
no flags Details

  None (edit)
Description Sergio Monteiro Basto 2004-09-06 16:23:45 EDT
Description of problem:

startkde 
the icons of desktop setting wizard for exempl has missing icons,
flags icons

Version-Release number of selected component (if applicable):
FC1 - KDE 3.1.4-5 

How reproducible:
after some upgrades and downgrades of Xorg and Xfree86

Steps to Reproduce:
1. startkde
2. cd ~
3. cat .xsession-errors
  
Actual results:

Invalid entry (missing ']') at /usr/bin/pam-panel-icon:1
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:3
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:4
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:5
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:6
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:7
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:8
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:9
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:10
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:11
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:12
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:13
Invalid entry (missing ']') at /usr/bin/pam-panel-icon:14
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:15
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:16
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:17
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:18
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:19
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:20
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:23
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:24
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:25
Invalid entry (second locale!?) at /usr/bin/pam-panel-icon:26
Invalid entry (second locale!?) at /usr/bin/pam-panel-icon:27
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:28
Invalid entry (second locale!?) at /usr/bin/pam-panel-icon:29
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:30
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:31
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:32
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:33
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:34
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:35
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:36
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:37
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:38
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:39
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:41
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:42
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:43
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:44
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:45
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:46
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:47
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:48
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:49
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:50
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:51
Invalid entry (second locale!?) at /usr/bin/pam-panel-icon:52
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:53
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:54
Invalid entry (second locale!?) at /usr/bin/pam-panel-icon:55
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:56
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:57
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:58
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:59
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:60
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:61
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:62
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:63
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:64
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:65
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:66
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:68
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:69
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:70
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:71
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:72
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:73
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:74
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:75
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:76
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:77
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:79
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:80
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:81
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:82
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:83
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:84
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:85
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:86
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:87
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:88
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:90
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:91
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:92
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:93
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:94
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:95
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:96
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:97
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:98
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:100
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:101
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:103
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:104
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:105
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:106
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:107
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:109
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:110
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:111
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:112
Invalid entry (missing '=') at /usr/bin/pam-panel-icon:113
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:2
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:4
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:5
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:7
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:8
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:9
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:10
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:11
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:13
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:14
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:16
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:17
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:19
Invalid entry (missing ']') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:20
Invalid entry (missing ']') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:21
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:23
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:24
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:25
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:26
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:27
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:28
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:29
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:30
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:31
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:32
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:33
Invalid entry (second locale!?) at
/usr/libexec/evolution/1.4/evolution-alarm-notify:34
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:35
Invalid entry (second locale!?) at
/usr/libexec/evolution/1.4/evolution-alarm-notify:37
Invalid entry (second locale!?) at
/usr/libexec/evolution/1.4/evolution-alarm-notify:38
Invalid entry (second locale!?) at
/usr/libexec/evolution/1.4/evolution-alarm-notify:39
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:40
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:43
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:44
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:45
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:47
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:51
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:52
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:53
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:54
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:55
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:56
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:57
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:58
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:59
Invalid entry (missing '=') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:60
Invalid entry (missing ']') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:61
Invalid entry (missing ']') at
/usr/libexec/evolution/1.4/evolution-alarm-notify:62


Expected results:

nothing ( don't have errors )

Additional info:

I think this errors could be one clue for the problem, since beginning
of fc1 after some updates, icons of some applications has disappear.
This happens in 2 or 3 computers that have the same software and that
I admin.
after this related with other problem I found this error messages that
could be the explanation 
other thing that I always do on my computers is:
cd .kde/share/
ln -s applnk-redhat .kde/share/applnk

because some aplications install is icons on .kde/share/applnk

thanks,
Comment 1 Sergio Monteiro Basto 2004-09-06 16:25:22 EDT
correction :
after login with kdm 
Comment 2 Ngo Than 2004-09-07 09:14:25 EDT
it's fixed in fc2.
Comment 3 Sergio Monteiro Basto 2004-09-09 20:39:46 EDT
I'm not planing test fc2, so can you be kindly ? and explain where is
the bug or how I can fix it on FC1.

thanks in advance
Comment 4 Matt Raible 2004-12-12 23:20:54 EST
I'm experiencing this with Fedora Core 3 after running "yum update". 
Do you know of anyway to solve this?
Comment 5 Sergio Monteiro Basto 2004-12-13 06:01:44 EST
no
Comment 6 Ngo Than 2004-12-13 08:02:04 EST
problem is that parseSingleConfigFile tried to parse the
/usr/bin/pam-panel-icon and prints the warnings by parsing because it's
not a config file! It's just a harmless warning in this case.

I don't see the warnings anymore since FC2 and FC3.
Comment 7 Sergio Monteiro Basto 2004-12-13 08:12:29 EST
haven't you read #4 after update FC3 this error appears again 

I had the same experince, icons of Desktop settings wizards,
disappears again after update Fedora Core 3 , with yum update 

Do you know of anyway to solve this?

that why I repopen this bug because We don't know how solve this 
Comment 8 Ngo Than 2004-12-13 08:25:10 EST
strange, does it happen with a new user? (create a new user and login
with the new on)
Comment 9 Sergio Monteiro Basto 2004-12-13 15:21:35 EST
Created attachment 108468 [details]
.xsession-errors on new user 

after install FC3 DVD and yum -y update just after update kde
Comment 10 Ngo Than 2004-12-13 15:40:26 EST
ok, the warnings did not appear with a new user. it seems there're
some old kde config files in your $HOME/.kde, which caused this problem.

i guess removing ksmserverrc and session in your $HOME/.kde/share/config
will fix this problem. Could you please try it? thanks
Comment 11 Sergio Monteiro Basto 2004-12-13 17:15:09 EST
Hi Than, thanks for reply 

I think we have a miss understood, my problem is not one Invalid entry
on .xsession.
My problem is for example, the desktop setting wizard, has missing
icons, to be more specific, all the flags icons are missing.
If you install a fresh FC1 or FC3 the icons appears, only after
upgrades of kde the icons disappears. Not only this icons, this icons
is one example.
Comment 12 Ngo Than 2004-12-13 17:22:32 EST
yes it's a misunderstanding here. sorry. could you please attach
screenshots that show the difference here? Thanks
Comment 13 Sergio Monteiro Basto 2004-12-13 17:57:40 EST
Created attachment 108473 [details]
where is Portuguese flag ?

Note You need to log in before you can comment on or make changes to this bug.