Bug 131947 - module drivers work incorrectly
module drivers work incorrectly
Status: CLOSED NEXTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
athlon Linux
medium Severity medium
: ---
: ---
Assigned To: Todd Barr
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-07 05:37 EDT by Lech Lobocki
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-04-16 00:48:39 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Lech Lobocki 2004-09-07 05:37:20 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803

Description of problem:
Running the standard distribution kernel, as well as any of the upgrades
kernel-2.6.5-1.358
kernel-2.6.7-1.494.2.2
kernel-2.6.8-1.521
causes problems with module drivers: vmware 4.5.2 loses access to a
CD-ROM, plustek_pp scanner gets into a dead loop (moving sensor back &
forth) while prescanning, sound chip (VIA 8233, ALSA drivers) produces
only thrashing voices. These problems cease after kernel recompilation
with some options turned off.

I recall similar problems with drivers on othes boxes, either Athlon
or Intel, ranging from sound distortion to a complete failure to
display graphics on a Radeon 5200, which may or may not be caused by
the same reason.

Apparently, the distribution-shipped kernels are too large. This
problem was mentioned in Brian's Ward "The Linux Problem Solver".

The distributed pre-compiled kernels should be made smaller (and,
perhaps, come in a larger variety), to better fit the target system.
A note in README, pointing out the necessity of kernel-recompilation
(with a related howto and a discussion of most effective options)
should be included. Perhaps the installer should be extended to
include assisted kernel compilation.

Version-Release number of selected component (if applicable):
kernel-2.6.5-1.358
kernel-2.6.7-1.494.2.2
kernel-2.6.8-1.521

How reproducible:
Always

Steps to Reproduce:
1. Try using WMWare 4.5.2 
2. Try using ALSA drivers on a VIA8233 chip
3. Try using plustek_pp
    

Actual Results:  VMWare 4.5.2 does not recognize a real CD-ROM (using
a copied track works, however)
Sound chip produces garbage
plustek_pp scanner gets into a dead loop while prescanning, the lamp
does not go off

Expected Results:  correct driver performance
(this was actually obtained after kernel re-compilation)

Additional info:

The particular machine is a Shuttle AK32A - based Athlon with 512 GB RAM.
Comment 1 Warren Togami 2004-09-07 05:41:26 EDT
I don't know where you got your information, but it is wrong.  I
personally use VMWare 4.5.2 very often with all kernels from FC2
through rawhide, and I have never lost the ability to use the CDROM
device.  About your VIA8233 and plustek_pp problem, I have personally
never tried those.
Comment 2 Lech Lobocki 2004-09-07 09:35:45 EDT
The information is not wrong - it comes straight from my experience
with the desktop I am facing right now. VMWare worked *without CD-ROM
access* with the kernel installed out of the box, and works quite fine
now, *after* kernel recompilation. This does not conflict with your
statement that the distribution kernel works fine on your configuration.

It is, however, helpful to hear about your experience. I cannot
exclude other possible reasons, such as conflicting modules. To
supplement my report, I include lsmod output below:

nls_utf8                2048  1
udf                    83204  0
vmnet                  29968  12
vmmon                  46240  0
ppdev                   8708  0
snd_pcm_oss            46008  0
snd_mixer_oss          15616  1 snd_pcm_oss
snd_ens1371            25572  0
snd_rawmidi            23076  1 snd_ens1371
snd_seq_device          6920  1 snd_rawmidi
snd_pcm                87944  2 snd_pcm_oss,snd_ens1371
snd_page_alloc          8968  1 snd_pcm
snd_timer              27268  1 snd_pcm
snd_ac97_codec         59652  1 snd_ens1371
snd                    48740  8
snd_pcm_oss,snd_mixer_oss,snd_ens1371,snd_rawmidi,snd_seq_device,snd_pcm,snd_timer,snd_ac97_codec
gameport                4352  1 snd_ens1371
soundcore               8032  1 snd
w83627hf               23812  0
eeprom                  6664  0
i2c_sensor              2688  2 w83627hf,eeprom
i2c_isa                 2304  0
i2c_viapro              6156  0
parport_pc             21952  1
lp                      9576  0
parport                36808  3 ppdev,parport_pc,lp
autofs4                21764  1
sunrpc                145252  1
8139too                22912  0
mii                     4096  1 8139too
floppy                 54320  0
sg                     30368  0
scsi_mod              107984  1 sg
uhci_hcd               29336  0
button                  5272  0
reiserfs              239700  2
Comment 3 Dave Jones 2005-04-16 00:48:39 EDT
Fedora Core 2 has now reached end of life, and no further updates will be
provided by Red Hat.  The Fedora legacy project will be producing further kernel
updates for security problems only.

If this bug has not been fixed in the latest Fedora Core 2 update kernel, please
try to reproduce it under Fedora Core 3, and reopen if necessary, changing the
product version accordingly.

Thank you.

Note You need to log in before you can comment on or make changes to this bug.