Bug 131974 - 4-port smc usb cardrider doesn't work because multilun is off
4-port smc usb cardrider doesn't work because multilun is off
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-07 12:32 EDT by Leonid Kanter
Modified: 2015-01-04 17:09 EST (History)
3 users (show)

See Also:
Fixed In Version: 2.6.9-1.649
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-04 05:33:02 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Leonid Kanter 2004-09-07 12:32:08 EDT
Description of problem:

I have 4-port (cf/ms/sm/mmc) cardreader by Standard Microsystems Corp.
(ID 0424:223a). Stock fedora kernel is able to recognize only first
port (CF), but it's unusable for me because I'm using mmc card. This
device is multilun device. I had to rebuild kernel with
CONFIG_SCSI_MULTILUN=y, and now all 4 ports work.

Version-Release number of selected component (if applicable):

2.6.8-1.9

How reproducible:

always

Steps to Reproduce:
1. Connect 4-port cardreader
  
Actual results:

cat /proc/scsi/scsi
Attached devices:
Host: scsi7 Channel: 00 Id: 00 Lun: 00
  Vendor: SMSC     Model: 223 U HS-CF      Rev: 1.95
  Type:   Direct-Access                    ANSI SCSI revision: 02

Expected results:

cat /proc/scsi/scsi
Attached devices:
Host: scsi7 Channel: 00 Id: 00 Lun: 00
  Vendor: SMSC     Model: 223 U HS-CF      Rev: 1.95
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi7 Channel: 00 Id: 00 Lun: 01
  Vendor: SMSC     Model: 223 U HS-MS      Rev: 1.95
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi7 Channel: 00 Id: 00 Lun: 02
  Vendor: SMSC     Model: 223 U HS-SM      Rev: 1.95
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi7 Channel: 00 Id: 00 Lun: 03
  Vendor: SMSC     Model: 223 U HS-SD/MMC  Rev: 1.95
  Type:   Direct-Access                    ANSI SCSI revision: 02
Comment 1 Warren Togami 2004-09-07 16:21:10 EDT
http://people.redhat.com/arjanv/2.6/RPMS.kernel/
I do not know where you got 2.6.8-1.9, but I don't think we shipped
that in any repository.  Please try the latest kernel from here.  If
that doesn't work, please report back so we can eventually add your
device to the multi LUN whitelist.
Comment 2 Leonid Kanter 2004-09-08 04:24:18 EDT
[leon@leon leon]$ uname -r
2.6.8-1.549
[leon@leon leon]$ cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: SMSC     Model: 223 U HS-CF      Rev: 1.95
  Type:   Direct-Access                    ANSI SCSI revision: 02
[leon@leon leon]$ lsusb
bash: lsusb: command not found
[leon@leon leon]$ /sbin/lsusb
....
Bus 001 Device 003: ID 0424:223a Standard Microsystems Corp.
....

Manufacturer part number of this unit is Hama 46965 (www.hama.de).
With multilun works perfectly - allows to copy from one card to other
in real time.
Comment 3 Alexander Kanevskiy 2004-09-11 18:26:19 EDT
You can try execute following lines:
echo "scsi add-single-device 0 0 0 1" > /proc/scsi/scsi
echo "scsi add-single-device 0 0 0 2" > /proc/scsi/scsi
echo "scsi add-single-device 0 0 0 3" > /proc/scsi/scsi
Comment 4 Leonid Kanter 2004-09-13 06:29:57 EDT
Looks like it works, but only if you connect reader for the first
time. If you disconnect reader and connect it again, luns 1, 2 and 3
will not be available until you reboot box.
[root@leon root]# uname -r
2.6.8-1.549
[root@leon root]# cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: SMSC     Model: 223 U HS-CF      Rev: 1.95
  Type:   Direct-Access                    ANSI SCSI revision: 02
[root@leon root]# echo "scsi add-single-device 0 0 0 3" > /proc/scsi/scsi
[root@leon root]# cat /proc/scsi/scsi
Attached devices:
Host: scsi0 Channel: 00 Id: 00 Lun: 00
  Vendor: SMSC     Model: 223 U HS-CF      Rev: 1.95
  Type:   Direct-Access                    ANSI SCSI revision: 02
Host: scsi0 Channel: 00 Id: 00 Lun: 03
  Vendor: SMSC     Model: 223 U HS-SD/MMC  Rev: 1.95
  Type:   Direct-Access                    ANSI SCSI revision: 02
....
disconnect device and connect it again
....
[root@leon root]# cat /proc/scsi/scsi
Attached devices:
Host: scsi3 Channel: 00 Id: 00 Lun: 00
  Vendor: SMSC     Model: 223 U HS-CF      Rev: 1.95
  Type:   Direct-Access                    ANSI SCSI revision: 02
[root@leon root]# echo "scsi add-single-device 0 0 0 2" > /proc/scsi/scsi
[root@leon root]# cat /proc/scsi/scsi
Attached devices:
Host: scsi3 Channel: 00 Id: 00 Lun: 00
  Vendor: SMSC     Model: 223 U HS-CF      Rev: 1.95
  Type:   Direct-Access                    ANSI SCSI revision: 02
[root@leon root]

So this is not a solution.
Comment 5 Dave Jones 2004-10-29 17:48:48 EDT
the latest FC3 builds should have this added to the whitelist.
try using at least -648 from rawhide.
Comment 6 Leonid Kanter 2004-11-04 04:56:32 EST
It works in -649

Note You need to log in before you can comment on or make changes to this bug.