Bug 132012 - Sad: No streamer on 'everything' installation
Sad: No streamer on 'everything' installation
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: distribution (Show other bugs)
3
noarch Linux
medium Severity low
: ---
: ---
Assigned To: Bill Nottingham
Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-07 17:00 EDT by Andy Harris
Modified: 2014-03-16 22:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-08 01:50:42 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Andy Harris 2004-09-07 17:00:14 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040803 Firefox/0.9.3

Description of problem:
On the FC1 and FC2, installation would give a streamer command line
prog that would work nicely with BT8*8 cards.

The FC3 doesn't seem to have this and I can't yum for it either.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1. Install FC3
2. Chose Everything option 
3. Look for /usr/streamer
4. Find its not there
    

Expected Results:  /usr/streamer would be presnt and play ball with
BT848 4 port video card as it does on FC1 and FC2

Additional info:
Comment 1 Bill Nottingham 2004-09-07 22:55:40 EDT
What package was it in in FC1/FC2?
Comment 2 Andy Harris 2004-09-08 01:34:56 EDT
Bill, /usr/bin/streamer is something I use on my home camera system,
and its just been 'there' in the past.  Here is some output from an
older system:

Here are outputs from uname and rpm:

Linux symphony.thirtover.com 2.4.22-1.2115.nptl #1 Wed Oct 29 15:42:51
EST 2003 i686 i686 i386 GNU/Linux

and rpm:
[root@symphony symweb]# rpm -V --whatprovides /usr/bin/streamer
Unsatisfied dependencies for xawtv-3.88-6: libGL.so.1, libICE.so.6,
libSM.so.6, libX11.so.6, libXaw.so.7, libXext.so.6, libXft.so.2,
libXmu.so.6, libXpm.so.4, libXrandr.so.2, libXrender.so.1, libXt.so.6,
libXv.so.1
prelink: /usr/bin/ntsc-cc: Could not parse `/usr/bin/ntsc-cc: error
while loading shared libraries: libXft.so.2: cannot open shared object
file: No such file or directory'
prelink: /usr/bin/ntsc-cc: at least one of file's dependencies has
changed since prelinking
S.?.....   /usr/bin/ntsc-cc
prelink: /usr/bin/pia: Could not parse `/usr/bin/pia: error while
loading shared libraries: libXft.so.2: cannot open shared object file:
No such file or directory'
prelink: /usr/bin/pia: at least one of file's dependencies has changed
since prelinking
S.?.....   /usr/bin/pia
prelink: /usr/bin/propwatch: Could not parse `/usr/bin/propwatch:
error while loading shared libraries: libXft.so.2: cannot open shared
object file: No such file or directory'
prelink: /usr/bin/propwatch: at least one of file's dependencies has
changed since prelinking
S.?.....   /usr/bin/propwatch
prelink: /usr/bin/rootv: Could not parse `/usr/bin/rootv: error while
loading shared libraries: libXft.so.2: cannot open shared object file:
No such file or directory'
prelink: /usr/bin/rootv: at least one of file's dependencies has
changed since prelinking
S.?.....   /usr/bin/rootv
prelink: /usr/bin/v4lctl: Could not parse `/usr/bin/v4lctl: error
while loading shared libraries: libXft.so.2: cannot open shared object
file: No such file or directory'
prelink: /usr/bin/v4lctl: at least one of file's dependencies has
changed since prelinking
S.?.....   /usr/bin/v4lctl
prelink: /usr/bin/xawtv: Could not parse `/usr/bin/xawtv: error while
loading shared libraries: libXft.so.2: cannot open shared object file:
No such file or directory'
prelink: /usr/bin/xawtv: at least one of file's dependencies has
changed since prelinking
S.?.....   /usr/bin/xawtv
prelink: /usr/bin/xawtv-remote: Could not parse
`/usr/bin/xawtv-remote: error while loading shared libraries:
libXft.so.2: cannot open shared object file: No such file or directory'
prelink: /usr/bin/xawtv-remote: at least one of file's dependencies
has changed since prelinking
S.?.....   /usr/bin/xawtv-remote
prelink: /usr/sbin/v4l-conf: Could not parse `/usr/sbin/v4l-conf:
error while loading shared libraries: libXft.so.2: cannot open shared
object file: No such file or directory'
prelink: /usr/sbin/v4l-conf: at least one of file's dependencies has
changed since prelinking
S.?.....   /usr/sbin/v4l-conf
Comment 3 Andy Harris 2004-09-08 01:38:28 EDT
Bill, despite all that 'Could not parse' and other stuff, this is
taken from a working system.  Here's a bit of /var/log/messages to
prove operation:

Sep  8 05:45:03 symphony kernel: bttv0: PLL can sleep, using XTAL
(28636363).
Sep  8 05:45:03 symphony kernel: bttv0: PLL: 28636363 => 35468950 .. ok
Sep  8 05:45:03 symphony kernel: bttv0: PLL can sleep, using XTAL
(28636363).
Sep  8 05:45:03 symphony kernel: bttv0: PLL: 28636363 => 35468950 .. ok
Comment 4 Bill Nottingham 2004-09-08 01:50:42 EDT
You want 'rpm -q --whatprovides ...', not 'rpm -V --whatprovides 

However, from the looks of it, it was in the xawtv package, which was
replaced by tvtime.
Comment 5 Andy Harris 2004-09-08 16:06:48 EDT
Bill, I've just looked up the functionality of the tvtime package:

a) There is not a command line capture option
b) Only the first interface of a BT8*8 card can be addressed

Therefore, I this this represents a fair loss of functionality.

I've written a 4 camera security program in Python that uses streamer 
to grab frames from each interface on /dev/video0

I can't find a xawtv package for FC3

Regards


Andy
Comment 6 Bill Nottingham 2004-09-08 16:12:05 EDT
xawtv is not in FC3, although it certainly should build if you wanted
to build the older version.

Note You need to log in before you can comment on or make changes to this bug.