Bug 1320262 - sandbox don't run GUI application
Summary: sandbox don't run GUI application
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: policycoreutils
Version: rawhide
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Petr Lautrbach
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-03-22 17:04 UTC by Fl@sh
Modified: 2016-07-20 07:19 UTC (History)
5 users (show)

Fixed In Version: policycoreutils-2.5-12.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-07-20 00:21:36 UTC


Attachments (Terms of Use)

Description Fl@sh 2016-03-22 17:04:50 UTC
Description of problem:
sandbox don't run any GUI application:


Version-Release number of selected component (if applicable):
policycoreutils-python-utils-2.5-4.fc25.x86_64

How reproducible:
as example:
/usr/bin/sandbox -X /usr/bin/firefox


Steps to Reproduce:
1.
2.
3.

Actual results:
Traceback (most recent call last):
  File "/usr/bin/sandbox", line 514, in <module>
    rc = sandbox.main()
  File "/usr/bin/sandbox", line 502, in main
    return self.__execute()
  File "/usr/bin/sandbox", line 454, in __execute
    import gtk
ImportError: No module named 'gtk'

Expected results:
run application in graphical mode

Additional info:
in F24 too

Comment 1 Petr Tuma 2016-05-31 19:15:31 UTC
Possibly related to https://bugzilla.redhat.com/show_bug.cgi?id=1253786 ? (Also seeing this with Fedora 24 beta release, policycoreutils-2.5-5.fc24.)

Comment 2 Fedora Update System 2016-07-15 11:54:25 UTC
checkpolicy-2.5-6.fc24, libselinux-2.5-9.fc24, libsemanage-2.5-5.fc24, libsepol-2.5-8.fc24, policycoreutils-2.5-12.fc24, secilc-2.5-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-84d1f77e58

Comment 3 Petr Tuma 2016-07-16 08:16:32 UTC
Still seeing the gtk problem with the latest updates, obviously depends on exact sandbox invocation:

> sandbox -X xterm
/usr/bin/sandbox:454: PyGIWarning: Gtk was imported without specifying a version first. Use gi.require_version('Gtk', '3.0') before import to ensure that the right version gets loaded.
  from gi.repository import Gtk

> sandbox -X --dpi 70 xterm
... (no gtk problem but fails due to what appears to be bug 1103622)

Comment 4 Joachim Frieben 2016-07-17 07:29:46 UTC
This appears to be a duplicate of bug 1103622.

Comment 5 Fedora Update System 2016-07-20 00:20:54 UTC
checkpolicy-2.5-6.fc24, libselinux-2.5-9.fc24, libsemanage-2.5-5.fc24, libsepol-2.5-8.fc24, policycoreutils-2.5-12.fc24, secilc-2.5-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 6 Joachim Frieben 2016-07-20 07:19:27 UTC
(In reply to Petr Tuma from comment #3)
Issue has been reported in new bug 1358138.


Note You need to log in before you can comment on or make changes to this bug.