Bug 132051 - genhdlist looks in RedHat/base not Fedora/base
genhdlist looks in RedHat/base not Fedora/base
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: anaconda (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-08 05:16 EDT by Bevis King
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-08 08:22:18 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Bevis King 2004-09-08 05:16:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7) Gecko/20040625

Description of problem:
The genhdlist command in /usr/lib/anaconda-runtime/ which is used to
rebuild the RPM package list still tries to find the hdlist file in
the subtree RedHat/base rather than it's present location of Fedora/base.

Version-Release number of selected component (if applicable):
anaconda-runtime-10.0.1-2

How reproducible:
Always

Steps to Reproduce:
1.  run /usr/lib/anaconda-runtime/genhdlist on kickstart image tree
2.
3.
    

Actual Results:  [root@willow Release3-test1-x86]#
/usr/lib/anaconda-runtime/genhdlist
/vol/eeion/kick/FedoraCore/Release3-test1-x86
error creating file
/vol/eeion/kick/FedoraCore/Release3-test1-x86/RedHat/base/hdlist: No
such file or directory
[root@willow Release3-test1-x86]# 

Expected Results:  Program looks in the perfectly valid file in
Fedora/base/hdlist instead.

Additional info:

This looks like a failure to update the program when the RPM tree moved.
Comment 1 Paul Nasrat 2004-09-08 08:22:18 EDT
Nope - genhdlist supports productpaths via:

 --productpath=Fedora

A good overview here: 
http://rau.homedns.org/twiki/bin/view/Anaconda/CustomizingAnaconda

Note You need to log in before you can comment on or make changes to this bug.