Bug 132103 - MAKEDEV attempts to do something which is not asked to do
MAKEDEV attempts to do something which is not asked to do
Status: CLOSED DUPLICATE of bug 131776
Product: Fedora
Classification: Fedora
Component: MAKEDEV (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nalin Dahyabhai
Brock Organ
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-08 15:59 EDT by Michal Jaegermann
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-09-08 15:59:52 EDT
Description of problem:

While booting with UDEV_TMPFS=yes and selinux=0 I am getting
on a screen:

Making extra nodes:  MAKEDEV: /dev/fd0: unable to reset file creation
context
MAKEDEV: /dev/fd1: unable to reset file creation context
.....  (long list skipped ) .....
MAKEDEV: /dev/net/tun: unable to reset file creation context
MAKEDEV: /dev/nvidiactl: unable to reset file creation context

What "file creation context"?  I have not only selinux=0 in
kernel boot parameters but even SELINUX=disabled in
/etc/sysconfig/selinux.  While I do not know what would happen
if I would enable these in the current situation MAKEDEV
definitely should not complain.

A sort of a nasty workaround here is to do in /sbin/start_udev

     make_extra_nodes >/dev/null 2>&1 && .....

instead of the current

     make_extra_nodes && .....

but this would not help at all with later MAKEDEV invocations.

Version-Release number of selected component (if applicable):
MAKEDEV-3.11-1

How reproducible:
Always
Comment 1 Bill Nottingham 2004-09-08 17:33:45 EDT

*** This bug has been marked as a duplicate of 131776 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:31 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.