Bug 132152 - syslog message: spin_is_locked on uninitialized spinlock 21feb370
syslog message: spin_is_locked on uninitialized spinlock 21feb370
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Jones
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-09 05:44 EDT by Pawel Orzechowski
Modified: 2015-01-04 17:09 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-27 13:27:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
gziped /var/log/messages file with the error (139.94 KB, text/plain)
2004-09-09 05:59 EDT, Pawel Orzechowski
no flags Details
Output from lsmod command (1.36 KB, text/plain)
2004-09-09 06:06 EDT, Pawel Orzechowski
no flags Details
Output from "ps -fe" command (8.40 KB, text/plain)
2004-09-09 06:07 EDT, Pawel Orzechowski
no flags Details

  None (edit)
Description Pawel Orzechowski 2004-09-09 05:44:32 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (compatible; Konqueror/3.2; Linux) (KHTML, like Gecko)

Description of problem:
Every few days /var/log/messages becomes full of a following message:
"kernel: mm/shmem.c:XXXX: spin_is_locked on uninitialized spinlock 21feb370."
After a restart of a machine the message is not showing anymore (until next time).


Version-Release number of selected component (if applicable):
kernel-2.6.8-1.521

How reproducible:
Couldn't Reproduce

Steps to Reproduce:
1.
2.
3.
    

Additional info:

"Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1187: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1193: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1004: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1013: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1004: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1013: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1004: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1013: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1004: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1013: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1004: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1013: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1004: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1013: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1004: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1013: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1004: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1013: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1004: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1013: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1004: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1013: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1004: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1013: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1004: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1013: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1004: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1013: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1004: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1013: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1004: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1013: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1004: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:1013: spin_is_locked on uninitialized spinlock 21feb370.                          Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:353: spin_is_locked on uninitialized spinlock 21feb370.                           Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:360: spin_is_locked on uninitialized spinlock 21feb370.                           Aug 30 10:46:35 orzechowskip kernel: mm/shmem.c:353: spin_is_locked on uninitialized spinlock 21feb370."
Comment 1 Arjan van de Ven 2004-09-09 05:46:56 EDT
are you using any kind of external kernel modules?
or any "less common" applications ?
Comment 2 Pawel Orzechowski 2004-09-09 05:59:21 EDT
Created attachment 103630 [details]
gziped /var/log/messages file with the error

The attached file is a syslog file from a few days (with some restarts of the
machine), showing how the error has occured.
Comment 3 Pawel Orzechowski 2004-09-09 06:05:19 EDT
There is no external modules or any "less common" applications I can 
think of (maybe rdesktop). I will attach lsmod and ps -fe output. 
Comment 4 Pawel Orzechowski 2004-09-09 06:06:14 EDT
Created attachment 103631 [details]
Output from lsmod command
Comment 5 Pawel Orzechowski 2004-09-09 06:07:46 EDT
Created attachment 103632 [details]
Output from "ps -fe" command
Comment 6 Dave Jones 2004-11-27 16:53:12 EST
Is this still a problem with the 2.6.9 based kernel update ?
Comment 7 Pawel Orzechowski 2004-11-29 17:05:08 EST
No, there is no problem any more. 
Comment 8 Pawel Orzechowski 2005-01-27 13:27:30 EST
Because the problem does not seem to occur anymore with current 
kernel releases, I'm closing this bug report as resolved. 

Note You need to log in before you can comment on or make changes to this bug.