Bug 132164 - gconf-editor displays errors when run
gconf-editor displays errors when run
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gconf-editor (Show other bugs)
3
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-09 10:19 EDT by Thomas J. Baker
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version: 2.8.0-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-12 13:59:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
GConf2-2.8.0.1-writable-flag.patch (404 bytes, patch)
2004-09-27 10:18 EDT, Mark McLoughlin
no flags Details | Diff
gconf-editor-2.8.0-warnings-on-startup.patch (4.14 KB, patch)
2004-09-27 10:19 EDT, Mark McLoughlin
no flags Details | Diff

  None (edit)
Description Thomas J. Baker 2004-09-09 10:19:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.2)
Gecko/20040803 Galeon/1.3.17

Description of problem:
Up to date rawhide system as of 9/9/2004.

katratzi> gconf-editor
Failed to write
"/etc/gconf/gconf.xml.defaults/apps/gconf-editor/%gconf.xml": Failed
to open
"/etc/gconf/gconf.xml.defaults/apps/gconf-editor/%gconf.xml.new":
Permission denied


Could not make directory "/etc/gconf/gconf.xml.mandatory/apps":
Permission denied
Failed to write "/etc/gconf/gconf.xml.mandatory/apps/%gconf.xml":
Failed to open "/etc/gconf/gconf.xml.mandatory/apps/%gconf.xml.new":
No such file or directory

Could not make directory "/etc/gconf/gconf.xml.mandatory/apps":
Permission denied
Could not make directory
"/etc/gconf/gconf.xml.mandatory/apps/gconf-editor": No such file or
directory
Failed to write
"/etc/gconf/gconf.xml.mandatory/apps/gconf-editor/%gconf.xml": Failed
to open
"/etc/gconf/gconf.xml.mandatory/apps/gconf-editor/%gconf.xml.new": No
such file or directory


It seems to come up OK after that but the errors are disconcerting.
I've duplicated the error on another rawhide system too.

Version-Release number of selected component (if applicable):
gconf-editor-2.7.91-1

How reproducible:
Always

Steps to Reproduce:
1. start gconf-editor
2.
3.
    

Additional info:
Comment 1 Mark McLoughlin 2004-09-27 09:20:37 EDT
Okay, the problem here is that gconf-editor has no reliable way of
figuring out whether the defaults/mandatory sources are writable by
the user.

In the markup backend we always assume that the source is writable and
just let writes fail - I think this is probably because the tree could
be partially writable.

So, I think we'd be better off just assuming that the whole tree isn't
writable if the toplevel isn't. If so, the GConf patch is simple:

@@ -331,6 +331,8 @@ resolve_address (const char *address,

     if (writable)
       flags |= GCONF_SOURCE_ALL_WRITEABLE;
+    else
+      flags |= GCONF_SOURCE_NEVER_WRITEABLE;


and we have sane code for gconf-editor, then.

Havoc, any thoughts?
Comment 2 Mark McLoughlin 2004-09-27 10:18:48 EDT
Created attachment 104373 [details]
GConf2-2.8.0.1-writable-flag.patch
Comment 3 Mark McLoughlin 2004-09-27 10:19:27 EDT
Created attachment 104374 [details]
gconf-editor-2.8.0-warnings-on-startup.patch
Comment 4 Mark McLoughlin 2004-09-27 10:21:36 EDT
Okay, moving this upstream:

  http://bugzilla.gnome.org/show_bug.cgi?id=144833
Comment 5 Mark McLoughlin 2004-10-12 13:58:43 EDT
* Tue Oct 12 2004 Mark McLoughlin <markmc@redhat.com> 2.8.0-2
- Add patch to fix warnings on startup (#132164)
- Add BuildRequies: scrollkeeper

Note You need to log in before you can comment on or make changes to this bug.