Bug 132176 - Internal compiler error compiling with -mpowerpc64
Internal compiler error compiling with -mpowerpc64
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: gcc (Show other bugs)
3.0
powerpc Linux
medium Severity medium
: ---
: ---
Assigned To: Jakub Jelinek
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-09 13:23 EDT by Mark Carter
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-21 16:02:07 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
preprocessed source from gcc (19.60 KB, text/plain)
2004-09-09 13:26 EDT, Mark Carter
no flags Details
Patch to disallow -m64 -mno-powerpc64 and -m32 -mpowerpc64 (909 bytes, patch)
2004-10-26 08:21 EDT, Jakub Jelinek
no flags Details | Diff

  None (edit)
Description Mark Carter 2004-09-09 13:23:52 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4.2)
Gecko/20040308

Description of problem:
Compiles fine without -mpowerpc64.  Generates internal compiler error
with "Preprocessed source stored into ./ccPAPfv0.out file, please
attach this to your bugreport."

Version-Release number of selected component (if applicable):
Red Hat Enterprise Linux AS release 3 (Taroon Update 3)

How reproducible:
Always

Steps to Reproduce:
1.configure atlas package from netlib.org with defaults
2.add -mpowerpc64 to the compiler options
3.make install arch="whatever configured in 1"
    

Actual Results:  make[2]: Entering directory
`/home/cartermd/ATLAS/ATLAS/bin/LinuxPower5gcc_m64'
/usr/bin/gcc -DL2SIZE=4194304 -I/home/cartermd/ATLAS/ATLAS/include
-I/home/cartermd/ATLAS/ATLAS/include/LinuxPower5gcc_m64
-I/home/cartermd/ATLAS/ATLAS/include/contrib  -DAdd__ -DStringSunStyle
-DATL_OS_Linux -DATL_GAS_LINUX_PPC -DATL_NCPU=8 -fomit-frame-pointer
-O3 -funroll-all-loops -mpowerpc64 -c ../atlas_tee.c
../atlas_tee.c: In function `main':
../atlas_tee.c:43: Internal compiler error in expand_call, at calls.c:3297
Please submit a full bug report,
with preprocessed source if appropriate.
See <URL:http://bugzilla.redhat.com/bugzilla/> for instructions.
Preprocessed source stored into ./ccexeq5D.out file, please attach
this to your bugreport.


Expected Results:  Successful compilation as obtained without
-mpowerpc64.  Need to build a 64-bit version of atlas.

Additional info: I do not see a way to attach the "preprocessed source
file"  This should be simple to do if I could see where to do it on
this form.
Comment 1 Mark Carter 2004-09-09 13:26:51 EDT
Created attachment 103645 [details]
preprocessed source from gcc

generated by internal compiler error
Comment 2 Jakub Jelinek 2004-10-26 05:58:50 EDT
-mpowerpc64 is not the switch used to create 64-bit binaries.
-m64 is the switch you probably meant to use, -mpowerpc64 just makes
GCC to emit 32-bit programs that are aware of running on 64-bit chip
and in some cases use e.g. 64-bit GR content.
Comment 3 Jakub Jelinek 2004-10-26 08:21:09 EDT
Created attachment 105791 [details]
Patch to disallow -m64 -mno-powerpc64 and -m32 -mpowerpc64

This is what I'm going to add to GCC 3.2.3-RH.
-m32 -mpowerpc64 only works since around October 2003 in GCC 3.4 and above
and it requires lots of patches to make it work.
Therefore GCC 3.2.3-RH will just disallow -mpowerpc64 when compiling 32-bit
programs and -mno-powerpc64 when compiling 64-bit programs.
Comment 4 Jakub Jelinek 2004-10-26 13:39:12 EDT
Patch added to gcc-3.2.3-47.
Comment 5 John Flanagan 2004-12-21 16:02:07 EST
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-584.html

Note You need to log in before you can comment on or make changes to this bug.