Bug 132179 - Building evolution-data-server srpm creates dependancy on installed libebook.so
Summary: Building evolution-data-server srpm creates dependancy on installed libebook.so
Status: CLOSED DUPLICATE of bug 132435
Alias: None
Product: Fedora
Classification: Fedora
Component: libtool   
(Show other bugs)
Version: 3
Hardware: All
OS: Linux
medium
medium
Target Milestone: ---
Assignee: Alexandre Oliva
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-09 18:05 UTC by Aaron Gaudio
Modified: 2007-11-30 22:10 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-03-28 20:03:15 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Aaron Gaudio 2004-09-09 18:05:24 UTC
Description of problem:
When rebuilding the evolution-data-server srpm, the resultant binary
rpm ends up depending on the libebook.so from an existing
evolution-data-server package. In my case, I was building the rpm
having an older version of evolution-data-server already installed
which provided libebook.so.7. Version 0.0.99 of the package, however,
provides libebook.so.8, and thus rpm reported a missing dependancy.

Version-Release number of selected component (if applicable):
evolution-data-server-0.0.99

How reproducible:
Always.

Steps to Reproduce:
1. With evolution-data-server-0.0.94 already installed, rebuild the
evolution-data-server-0.0.99 srpm.
2. Attempt to install evolution-data-server-0.0.99 binary rpm, using
rpm -Uvh.
  
Actual results:
Get a dependency issue saying evolution-data-server-0.0.99 requires
libebook.so.7.

Expected results:
evolution-data-server-0.0.99 depends on libebook.so.8, which it
provides itself.

Additional info:

Comment 1 Dave Malcolm 2004-09-09 20:34:04 UTC
Thanks...  I've seen something like this before, last time it happened
to me was with libgal2.

I believe a stray  -L/usr/lib is making its way into the link line,
possibly via a -rpath in the Makefile.in ?

This means that if you have the older e-d-s-devel package installed,
it links against the installed so files, rather than the newly built
ones.  The easy workaround is to uninstall e-d-s-devel before
rebuilding e-d-s.

I suspect there's a subtle bug in libtool, but it may be a separate
problem with the e-d-s configure.in and Makefile.am files.

Adding dreed to cc in the hope he can comment further.

Comment 2 Dave Malcolm 2005-03-28 18:30:50 UTC
Changing component to "libtool" for now

Comment 3 Alexandre Oliva 2005-03-28 20:03:15 UTC

*** This bug has been marked as a duplicate of 132435 ***


Note You need to log in before you can comment on or make changes to this bug.