Bug 132202 - IBM T40p: screen goes blank after loading radeonfb
Summary: IBM T40p: screen goes blank after loading radeonfb
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: initscripts   
(Show other bugs)
Version: rawhide
Hardware: All
OS: Linux
medium
high
Target Milestone: ---
Assignee: Bill Nottingham
QA Contact: Brock Organ
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-09 20:42 UTC by Kaj J. Niemi
Modified: 2014-03-17 02:48 UTC (History)
1 user (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 11:03:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
dmesg (13.62 KB, text/plain)
2004-09-09 20:43 UTC, Kaj J. Niemi
no flags Details
lspci -vvv (9.19 KB, text/plain)
2004-09-09 20:43 UTC, Kaj J. Niemi
no flags Details

Description Kaj J. Niemi 2004-09-09 20:42:28 UTC
Description of problem:
An IBM T40p laptop running kernel 1.549 (was reproduceable with 1.540,
too) and booting into single user mode blanks the screen soon after
the "Initializing ... storage network audio" (around line 208 in
rc.sysinit).

The problematic module is radeonfb.

I am unsure how to proceed with this :) Attached is dmesg and lspci

Version-Release number of selected component (if applicable):
initscripts-7.77-1
udev-030-22
kernel-2.6.8-1.549
kernel-2.6.8-1.540

How reproducible:
Always.

Steps to Reproduce:
1. Boot.
2. Wait for "Initializing devices .. storage network audio"
3. 
  
Actual results:
Screen goes blank but cursor is not turned off. 


Additional info:
Acting on a hunch I did "/sbin/service kudzu start" in single mode and
the screen returned to colors.

I'm not sure if I should file this under kernel, udev or initscripts.

Easiest workaround for now was to add to rc.sysinit

        if [ "$module"x != "radeonfb"x ]; then
                modprobe $module >/dev/null 2>&1
        fi


Let me know if there's any other info you need to pinpoint this :)

Comment 1 Kaj J. Niemi 2004-09-09 20:43:24 UTC
Created attachment 103651 [details]
dmesg

Comment 2 Kaj J. Niemi 2004-09-09 20:43:50 UTC
Created attachment 103652 [details]
lspci -vvv

Comment 3 Kaj J. Niemi 2004-09-21 11:03:46 UTC
Not an issue in 581. Closing as works for me.


Note You need to log in before you can comment on or make changes to this bug.