Bug 132231 - (xircom_cb?) System hangs with kernel panic right after loading S24pcmcia run command script.
(xircom_cb?) System hangs with kernel panic right after loading S24pcmcia run...
Status: CLOSED WORKSFORME
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: John W. Linville
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-09 21:25 EDT by Steve Valimaki
Modified: 2007-11-30 17:07 EST (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-04 14:38:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Steve Valimaki 2004-09-09 21:25:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030922

Description of problem:
This problem is easily replicated (every time I boot). If I move the
S24pcmcia run command script in rc3.d and rc5.d directories to some
filename that doesn't execute, like orig_S24pcmcia, the system boots
up and run's just fine.
This is a Dell Latitude 650 laptop.
The pcmcia card installed is Xircom RealPort Cardbus Ethernet 10/100 +
Modem 56, model # RBEM56G-100.

I would be happy to pass on any config files, log files etc...

Version-Release number of selected component (if applicable):
kernel-pcmcia-cs-3.1.31-13

How reproducible:
Always

Steps to Reproduce:
1. Boot up the system
2. Wait for pcmcia run command to execute
3. Power cycle the laptop since the laptop is hung 
    

Actual Results:  If I move the run command script to something else so
I can boot (moving it in single user mode before it can execute), then
manually start (service pcmcia start) once in multi user mode, the
system gets the same kernel panic and is hung.

Expected Results:  If the pcmcia run command script executed without
failure, I would be able to boot up with services running.

Additional info:

See Description field
Comment 1 Steve Valimaki 2004-09-10 08:30:36 EDT
One additional note, I did try to load the pcmcia run command before
and after the network script executes. It really didn't matter since
manually running the command still gives a kernel panic.

BTW, I put down that the laptop is a 586 by mistake, it is an Intel 686.
Comment 2 Steve Valimaki 2004-09-18 07:31:03 EDT
I've replaced the Xircom PCMCIA card with a 3COM card and do not get
any kernel panics. This is definitely related to the Xircom
card/driver. I'm not sure what to do about fixing this (not sure what
driver changes to make). I'll look around and see if there is an
updated driver.
Comment 3 Daniel Button 2004-09-24 09:59:10 EDT
I have a Toshiba Portege 7200Cte.  I have exactly the same problem. 
It doesn't matter is cards are in the PCMCIA slot or not.  If I try to
access the S24pcmcia script, machine crashes.  Need to do a hard boot
to restart.  Happens 100% of the time.  Rebuilt machine several times
to see if problem is part of installation.  Same results.
Comment 5 Jeff Garzik 2005-02-18 02:57:40 EST
xircom_tulip_cb should not be used, but xircom_cb should be used.

I wonder if this is related to bug #103562 ?
Comment 6 John W. Linville 2005-04-04 16:19:21 EDT
I am unable to recreate this using RHEL3 U5 Beta on a Toshiba Satellite 
2595CDS.  Are you still experiencing this problem with the latest available 
RHEL3? 
Comment 7 John W. Linville 2005-05-04 14:38:04 EDT
Closed due to lack of response.  Please reopen if the requested information 
becomes available. 

Note You need to log in before you can comment on or make changes to this bug.