Bug 13224 - [text-install] Installer puts line breaks in the middle of words
[text-install] Installer puts line breaks in the middle of words
Status: CLOSED RAWHIDE
Product: Red Hat Linux
Classification: Retired
Component: anaconda (Show other bugs)
7.1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Matt Wilson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2000-06-29 14:28 EDT by Christian Rose
Modified: 2008-05-01 11:37 EDT (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-10-23 19:37:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rose 2000-06-29 14:28:23 EDT
This is a message in the .sv.po file:

#: ../textw/lilo_text.py:18 ../textw/silo_text.py:14
msgid ""
"A few systems will need to pass special options to the kernel at boot time
"  
"for the system to function properly. If you need to pass boot options to
the "
"kernel, enter them now. If you don't need any or aren't sure, leave this "
"blank." 
msgstr ""
"Negra system behvver skicka speciella flaggor till kdrnan vid uppstart fvr
" 
"att systemet skall fungera ordentligt. Om du behvver skicka sedana
flaggor, "
"skriv in dem nu. Om du inte behvver negra, eller om du inte dr sdker, let
"
"fdltet vara tomt."

And this is what gets displayed by the text mode installer (with the actual
line breaks):

Negra system behvver skicka speciella flaggor till kdrnan vid  
uppstart fvr att systemet skall fungera ordentligt. Om du behvv
er skicka sedana flaggor, skriv in dem nu. Om du inte behvver
negra, eller om du inte dr sdker, let fdltet vara tomt.

Notice the break in the middle of the word "behvver". I saw this behavior
in other longer messages (like the
"welcome to..." message) too. It would be nice if the installer didn't put
line breaks in the middle of words.
Comment 1 Matt Wilson 2000-06-30 16:23:50 EDT
This is almost certainly due to buggy or missing locale information in glibc
2.1.90.

Comment 2 Christian Rose 2000-07-13 17:37:15 EDT
Bug is still present in beta3.
Comment 3 Matt Wilson 2000-07-14 22:26:36 EDT
We need to change the installer to use the sv_SE locale, sv_SV is invalid now.
Comment 4 Christian Rose 2000-07-22 21:36:41 EDT
I saw the "behvver" thing in beta4 too. Appearantly it's still an issue.
Comment 5 Christian Rose 2000-08-01 19:14:41 EDT
This is still happening in Pinstripe.
Comment 6 Arenas Belon, Carlo Marcelo 2000-08-02 00:09:08 EDT
on LANG=es installs there are words that got sticked to the next and "-"
characters on the middle of the screen.
Comment 7 Christian Rose 2000-08-27 13:22:54 EDT
This is still happening in RC2.
Comment 8 Michael Fulbright 2000-10-23 15:44:27 EDT
Is this problem present in the final 7 release?
Comment 9 Christian Rose 2000-10-23 19:37:02 EDT
I just checked, couldn't reproduce it with Red Hat 7 gold.

Note You need to log in before you can comment on or make changes to this bug.