Bug 132244 - df output on large nfs filesystem terabyte
df output on large nfs filesystem terabyte
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: kernel (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Rik van Riel
Brian Brock
:
Depends On:
Blocks: 132525
  Show dependency treegraph
 
Reported: 2004-09-10 03:49 EDT by Helmut Pedit
Modified: 2007-11-30 17:07 EST (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 15:56:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
strace output of df -k (4.07 KB, text/plain)
2004-09-10 03:53 EDT, Helmut Pedit
no flags Details
strace output of df -i (4.06 KB, text/plain)
2004-09-10 03:54 EDT, Helmut Pedit
no flags Details

  None (edit)
Description Helmut Pedit 2004-09-10 03:49:35 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; SunOS sun4u; en-US; rv:1.7)
Gecko/20040615 Firefox/0.9

Description of problem:
see related closed bugs #126657 and #128418

the problem should be solved with RHEL 3 U3 AS and WS (see
http://rhn.redhat.com/errata/RHBA-2004-433.html)
but still appears in different form

Using df for a 2700 MB filesystem mounted via nfs from an Origin 3800
produces the following output:

'cd /mnt/o3800'
'df -k .'

Filesystem               1K-blocks   Used                 Available 
xxx.yyy.zzz:/abc/scratch         1      1                         1

Use%  Mounted on
  0% /mnt/o3800

The correct values should be

xxx.yyy.zzz:/abc/scratch 2836004864  970191548            1865813316  

35%  /mnt/o3800


Also of interest

'df -i'

Filesystem                     Inodes      IUsed        IFree     
IUse% Mounted on  
 
xxx.yyy.zzz:/abc/scratch   4294967295          0   4294967295        
0% /mnt/o3800

The correct values should be
xxx.yyy.zzz:/abc/scratch    2836135936    147301   2835988635        
%1 /mnt/o3800



Version-Release number of selected component (if applicable):
kernel-2.4.21-20.EL

How reproducible:
Always

Steps to Reproduce:
1.cd /mnt/o3800
2.df -k .
3.
    

Additional info:
Comment 1 Helmut Pedit 2004-09-10 03:53:30 EDT
Created attachment 103675 [details]
strace output of df -k
Comment 2 Helmut Pedit 2004-09-10 03:54:19 EDT
Created attachment 103676 [details]
strace output of df -i
Comment 3 Rik van Riel 2004-09-10 06:55:56 EDT
Helmut, we are working on the following things for U4:

1) add the (f)statfs64 system call to x86 and PPC64 kernels (those two
run with 32 bit /bin/df)

2) add a ->statfs64 operation to the NFS filesystem

3) teach /bin/df to not truncate 64 bit values when running with 32
bits, like it currently does
Comment 4 Tim Waugh 2004-09-14 11:02:40 EDT
Clarification: (3) is more than just 'recompile with
--enable-largefile' I think, from discussions with Rik the other day.
Comment 5 Rik van Riel 2004-09-22 17:40:34 EDT
A patch with statfs64 system call has been submitted for inclusion in
the RHEL3 kernel today.
Comment 6 Ernie Petrides 2004-09-24 05:55:17 EDT
A fix for this problem has just been committed to the RHEL3 U4
patch pool this evening (in kernel version 2.4.21-20.11.EL).
Comment 7 Tim Waugh 2004-09-24 06:12:44 EDT
(I think there is still work to do on coreutils.)
Comment 8 Ernie Petrides 2004-09-27 21:51:18 EDT
*** Bug 133833 has been marked as a duplicate of this bug. ***
Comment 9 John Flanagan 2004-12-20 15:56:34 EST
An errata has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-550.html

Note You need to log in before you can comment on or make changes to this bug.