Bug 13228 - aacraid statically linked to SMP kernel fails
Summary: aacraid statically linked to SMP kernel fails
Status: CLOSED CURRENTRELEASE
Alias: None
Product: Red Hat Linux
Classification: Retired
Component: kernel   
(Show other bugs)
Version: 7.1
Hardware: i386 Linux
medium
medium
Target Milestone: ---
Assignee: Michael K. Johnson
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2000-06-29 19:11 UTC by Matt Domsch
Modified: 2008-05-01 15:37 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2000-08-01 16:21:08 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
NR_CPUs + PCI IDs update (5.99 KB, patch)
2000-07-24 21:10 UTC, Matt Domsch
no flags Details | Diff
SMP static-link panic fix patch (3.58 KB, patch)
2000-07-24 21:11 UTC, Matt Domsch
no flags Details | Diff
fixed 1.0.5 patch (3.41 KB, patch)
2000-07-24 21:33 UTC, Matt Domsch
no flags Details | Diff

Description Matt Domsch 2000-06-29 19:11:55 UTC
The aacraid driver v1.0.3, when statically linked into an SMP kernel, 
fails.
Kernel panic: CPU 0 trying to acquire lock again: lock count = 1
In interrupt handler - not syncing

When loaded as a module, it works fine.  Adaptec and Dell are 
investigating.

Comment 1 Matt Domsch 2000-07-24 21:10:45 UTC
Created attachment 1494 [details]
NR_CPUs + PCI IDs update

Comment 2 Matt Domsch 2000-07-24 21:11:23 UTC
Created attachment 1495 [details]
SMP static-link panic fix patch

Comment 3 Matt Domsch 2000-07-24 21:12:26 UTC
From: Boerner, Brian [Brian_Boerner@ntc.adaptec.com]
Sent: Monday, July 24, 2000 3:48 PM
To: 'dledford@redhat.com'; 'matt_domsch@dell.com'
Cc: Boerner, Brian
Subject: Adaptec aacraid 1.0.5 patch - fix for SMP kernel panic

Turns out the fix was actually quite simple. Looks like we were overriding
the top level
makefiles CFLAGS variable and picking up the UP define for spinlock_t.

Anyway, to make a long story short, the problem is solved.

Doug, I previously sent you the 1.0.4 patch, did you get it?

If so, the patches need to be applied in numerical order. So, apply the
1.0.4 patch
and then the 1.0.5 patch.

Thanks so much for you patients.

Cheers!!
 -bmb-


Comment 4 Matt Domsch 2000-07-24 21:33:16 UTC
Created attachment 1497 [details]
fixed 1.0.5 patch

Comment 5 Matt Domsch 2000-08-01 16:21:06 UTC
Fixed in beta 5 with version 1.0.5 of the aacraid driver.


Note You need to log in before you can comment on or make changes to this bug.