Bug 132293 - [PATCH] rstatd using /proc/stat
[PATCH] rstatd using /proc/stat
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: rusers (Show other bugs)
3.0
All Linux
medium Severity high
: ---
: ---
Assigned To: Phil Knirsch
Ben Levenson
:
Depends On:
Blocks: 123574
  Show dependency treegraph
 
Reported: 2004-09-10 13:49 EDT by Suzanne Hillman
Modified: 2015-03-04 20:14 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-12-20 20:23:10 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
use /proc/partitions, not /proc/stat (4.32 KB, patch)
2004-09-10 13:50 EDT, Suzanne Hillman
no flags Details | Diff

  None (edit)
Description Suzanne Hillman 2004-09-10 13:49:47 EDT
[This is a clone of bug #131245, so that there are separate bugs for
RHEL3 and RHEL2.1]

---

Opened by Tom "spot" Callaway (tcallawa@redhat.com) on 2004-08-30 09:30

In RHEL 2.1 & 3, rstatd is currently using /proc/stat to gather disk
usage data. Since /proc/partitions is the "correct" mechanism for RHEL
2.4 kernels to be using, I've written a patch to fix this bug.

This is related to
http://bugzilla.redhat.com/bugzilla/show_bug.cgi?id=123136


Additional Comment #2 From Robert Perkins (rperkins@redhat.com)  on
2004-09-08 13:17 -------

Moving to sustaining engineering queue so it can go on the "mustfix"
list.  
Rob -

Can you move the following BZ to the U4/U6 lists?

Brian

On Mon, 2004-08-30 at 10:17, Tom 'spot' Callaway wrote:

>> Brian,
>> 
>> In working with the Chicago Mercantile Exchange, I found an issue with
>> rstatd getting its disk data from /proc/stat. I wrote a patch to
have it
>> instead get disk data from /proc/partitions, and both myself and CME
>> have tested it, finding that it works fine.
>> 
>> This is BZ 131245, (related to 123136). Phil asked me to get someone in
>> PM to assign this as a MustFix errata for RHEL 2.1 (U6) and RHEL 3
(U4),
>> can you help me out here?
>> 
>> Thanks in advance,
>> 
>> ~spot
>> ---
>> Tom "spot" Callaway <tcallawa(a)redhat*com> LCA, RHCE 
>> Red Hat Sales Engineer || Aurora Linux Project Leader
>> 
>> "If you are going through hell, keep going."
>> - Sir Winston Churchill


------- Additional Comment #3 From Robert Perkins
(rperkins@redhat.com) on 2004-09-08 13:17 -------

Note this should be cloned for RHEL3 U4.
Comment 1 Suzanne Hillman 2004-09-10 13:50:43 EDT
Created attachment 103693 [details]
use /proc/partitions, not /proc/stat
Comment 2 Suzanne Hillman 2004-09-10 13:51:42 EDT
Putting into U4's MUSTFIX.
Comment 3 Phil Knirsch 2004-09-13 12:00:08 EDT
Packages built in dist-3.0E-U4.

Will set to modified when i have done the opened and written the erratas.

Read ya, Phil
Comment 4 Phil Knirsch 2004-09-20 08:28:34 EDT
OK, errata opened.

Setting to modified.

Read ya, Phil
Comment 5 John Flanagan 2004-12-20 20:23:11 EST
An advisory has been issued which should help the problem 
described in this bug report. This report is therefore being 
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files, 
please follow the link below. You may reopen this bug report 
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2004-477.html

Note You need to log in before you can comment on or make changes to this bug.