Bug 132295 - (IT_46695) [RHEL3 IPF][PATCH] lastcomm outputs incorrect value
[RHEL3 IPF][PATCH] lastcomm outputs incorrect value
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: psacct (Show other bugs)
3.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Ivana Varekova
:
Depends On:
Blocks: 132991
  Show dependency treegraph
 
Reported: 2004-09-10 14:05 EDT by Martin Hunt
Modified: 2007-11-30 17:07 EST (History)
2 users (show)

See Also:
Fixed In Version: RHBA-2005-167
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-05-19 19:39:14 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
fixes (958 bytes, patch)
2004-12-06 10:17 EST, Florian La Roche
no flags Details | Diff
fixes2 (3.39 KB, patch)
2004-12-06 10:17 EST, Florian La Roche
no flags Details | Diff

  None (edit)
Description Martin Hunt 2004-09-10 14:05:33 EDT
[Description]
lastcomm on IA64 command shows wrong elapsed time
(10.24 times bigger than time command value) as follow:

# time dd if=/dev/zero of=file bs=1024 count=3000
3000+0 records in
3000+0 records out
                                                                     
         
real    0m0.050s
user    0m0.004s
sys     0m0.047s

# lastcomm dd
dd                      root     stdout     0.50 secs Mon Aug 16 03:33

Customer cannot do accounting his system correctly. This gives the
serious impact to his system's
security and/or management.

[Environment]
RHEL 3 AS IPF
- kernel-2.4.21-15.EL
- glibc-kernheaders-2.4-8.32
- psacct-6.3.2-27

[Additional Info]
This seems to be caused by mismatching between kernel's frequency (HZ
= 1024)
and  accounting's (HZ = 100) on IA64.

in /usr/src/linux-2.4/include/asm-ia64/param.h:
#define HZ 1024

in /usr/include/linux/acct.h:
#define AHZ 100

If AHZ is set as 1024 and re-build psacct package, then lastcomm shows
correct value.
Similar bug has been reported at BZ#114617, 89959.

[Environment]
RHEL 3 AS IPF
- kernel-2.4.21-15.EL
- glibc-kernheaders-2.4-8.32
- psacct-6.3.2-27
Comment 1 Martin Hunt 2004-09-10 14:07:41 EDT
BZ 117817 is the same bug, except for RHEL2.1
Comment 2 Martin Hunt 2004-09-10 14:11:46 EDT
BZ117817 contains patch.
Comment 4 Charlie Bennett 2004-09-27 12:20:52 EDT
Erratum RHBA-2004:497-03
Comment 6 James Laska 2004-12-03 15:12:22 EST
Moving back to ASSIGNED as this issue will not be resolved in 
RHBA-2004:497.
Comment 13 Tim Powers 2005-05-19 19:39:14 EDT
An advisory has been issued which should help the problem
described in this bug report. This report is therefore being
closed with a resolution of ERRATA. For more information
on the solution and/or where to find the updated files,
please follow the link below. You may reopen this bug report
if the solution does not work for you.

http://rhn.redhat.com/errata/RHBA-2005-211.html

Note You need to log in before you can comment on or make changes to this bug.