Bug 132314 - after an updade assorted flak from devlabel
after an updade assorted flak from devlabel
Status: CLOSED DUPLICATE of bug 132224
Product: Fedora
Classification: Fedora
Component: devlabel (Show other bugs)
3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-10 16:40 EDT by Michal Jaegermann
Modified: 2014-03-16 22:48 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:34 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michal Jaegermann 2004-09-10 16:40:45 EDT
Description of problem:

After today update to devlabel-0.48.03-4 I am greeted on boot
with the following:

/sbin/devlabel: line 895: /etc/sysconfig/devlabel.d/ignore_list: No
such file or directory
/sbin/devlabel: line 896: /etc/sysconfig/devlabel.d/proc_partitions:
No such file or directory
grep: /etc/sysconfig/devlabel.d/ignore_list: No such file or directory
/sbin/devlabel: line 920: [: -eq: unary operator expected
grep: /etc/sysconfig/devlabel.d/ignore_list: No such file or directory
/sbin/devlabel: line 920: [: -eq: unary operator expected
grep: /etc/sysconfig/devlabel.d/ignore_list: No such file or directory
/sbin/devlabel: line 144: [: -gt: unary operator expected
grep: /etc/sysconfig/devlabel.d/ignore_list: No such file or directory
.....
(many more lines complaining about line 144)

BTW - checking with 'grep -c' if grep found something is
_obviously_ an ass-backwards way to do that as amply illustrated
by the above and requires an extra level of quoting.
There is 'if grep -q ..... >/dev/null 2>&1; then ... ;fi'
construct for such things.

Oh, and a querry to bugzilla about 'devlabel' returns always
"Zarro Boogs found"; which is clearly bogus.

Version-Release number of selected component (if applicable):
devlabel-0.48.03-4
Comment 1 Bill Nottingham 2004-09-10 16:48:11 EDT
This is fi

*** This bug has been marked as a duplicate of 132224 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:34 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.