Bug 132328 - ccsd is unable to update cluster conf file to others
ccsd is unable to update cluster conf file to others
Status: CLOSED CURRENTRELEASE
Product: Red Hat Cluster Suite
Classification: Red Hat
Component: gfs (Show other bugs)
4
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Jonathan Earl Brassow
GFS Bugs
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-10 17:36 EDT by Corey Marthaler
Modified: 2010-01-11 21:57 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-21 17:27:44 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Corey Marthaler 2004-09-10 17:36:53 EDT
Description of problem:
I had ccsd running and a cman quorum on the morph-cluster.

[root@morph-03 root]# cat /proc/cluster/nodes
Node  Votes Exp Sts  Name
   1    1    6   M   morph-01
   2    1    6   M   morph-04
   3    1    6   M   morph-02
   4    1    6   M   morph-05
   5    1    6   M   morph-03
   6    1    6   M   morph-06

I then went on morph-02, bumped the version number of the cluster.conf
file, sent ccsd a SIGHUP to go propagate the new file, and it failed:

Sep 10 16:29:34 morph-02 ccsd[2272]: Failed to receive
COMM_UPDATE_NOTICE_ACK from morph-06
Sep 10 16:29:34 morph-02 ccsd[2272]: Failed to update remote nodes.
Sep 10 16:29:34 morph-02 ccsd[2272]: Update failed.
Sep 10 16:29:34 morph-02 ccsd[2272]: Select failed: Interrupted system
call

from morph-06:
Sep 10 16:29:36 morph-06 ccsd[2276]: Unexpected communication type...
ignoring.
Sep 10 16:29:36 morph-06 ccsd[2276]: Error while responding to cluster
message: Invalid argument

How reproducible:
Always

Actual Results:  the version never got bumped on the other nodes

Expected Results:  the version should get bumped on the other nodes
Comment 1 Jonathan Earl Brassow 2004-09-13 12:56:03 EDT
please provide the following:

> ls -l /etc/cluster/cluster.conf

Comment 2 Jonathan Earl Brassow 2004-09-13 14:43:37 EDT
The recent changes to magma should fix this.  Magma was not allowing 
msg_send to send more than 1024 bytes.  This seems to be related to the 
problem you are seeing.  (This is how I reproduced it.)
Comment 3 Corey Marthaler 2004-09-14 18:55:30 EDT
The files do now get updated however I'm curious why there is always 
a failed select message after the update? 
 
Select failed: Interrupted system call 
Comment 4 Jonathan Earl Brassow 2004-09-14 19:08:38 EDT
Since a signal is used to do the update, the select gets interrupted.  This is not 
really an error, so I suppose it could be checked/taken out.
Comment 5 Corey Marthaler 2004-09-21 17:27:44 EDT
fix verified and nolonger a "Select failed" message. 
Comment 6 Kiersten (Kerri) Anderson 2004-11-16 14:10:42 EST
Updating version to the right level in the defects.  Sorry for the storm.

Note You need to log in before you can comment on or make changes to this bug.