Bug 1323736 - Wireless adapter randomly confused with wired adapter
Summary: Wireless adapter randomly confused with wired adapter
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: NetworkManager
Version: 24
Hardware: x86_64
OS: Linux
unspecified
high
Target Milestone: ---
Assignee: Lubomir Rintel
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-04 14:37 UTC by Michele
Modified: 2016-08-19 19:49 UTC (History)
4 users (show)

Fixed In Version: NetworkManager-1.2.4-2.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-08-19 19:49:59 UTC
Type: Bug


Attachments (Terms of Use)
[PATCH] platform: add logs to debug link type matching (4.49 KB, patch)
2016-04-21 11:28 UTC, Beniamino Galvani
no flags Details | Diff
Log (267.69 KB, text/plain)
2016-05-09 09:16 UTC, Michele
no flags Details


Links
System ID Private Priority Status Summary Last Updated
GNOME Bugzilla 764803 0 None None None 2016-04-21 11:47:00 UTC

Description Michele 2016-04-04 14:37:51 UTC
Description of problem:
On a freshly installed (and updated) Fedora 24 Alpha, immediately after boot the wireless adapter is not correctly recognized by Gnome and is shown as a wired adapter instead. This is visible in the top-right applet as well as in the settings. It is impossible then to connect to any wireless network (I am reporting this from another OS).
Let me know how can I help to fix this.

Version-Release number of selected component (if applicable):


How reproducible:


Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:

Comment 1 Michele 2016-04-04 14:39:51 UTC
Forgot to mention that the problem occurred on a Surface Pro 3.

Comment 2 Michele 2016-04-18 18:22:20 UTC
To this day, the released updates did not fix the problem. I guess it's related to the new networkmanager 1.2 infrastructure? With Fedora 23 it worked fine.
I also noticed that the few times the adapter is correctly recognized not always it manages to find the wireless networks available. Let's say that I have to be lucky, because 50% of the times it doesn't find any network.

Both Fedora 23 and Windows 10 work fine.

Please let me know how can I help to troubleshoot the problem since if not fixed prevents Fedora to be usable on my pc.

Comment 3 Beniamino Galvani 2016-04-21 11:28:40 UTC
Created attachment 1149431 [details]
[PATCH] platform: add logs to debug link type matching

Hi,

I've tried with different wifi adapters but this issue didn't happen
to me. It would be useful if you could try a version of NM with the
attached patch. If you need pre-compiled RPMs for F24 you can download
them from:

 http://people.redhat.com/~bgalvani/NM/rh1323736/

and install with 'rpm -Fvh *.rpm'. After, modify the line

#level=TRACE

to:

level=TRACE

in /etc/NetworkManager/NetworkManager.conf and run

 systemctl restart NetworkManager

Now, when the problem appears again, please run:

 journalctl -u NetworkManager -b > log.txt

and attach the log.txt file to this bugzilla. Thanks!

Comment 5 Michele 2016-05-09 09:14:46 UTC
I still have to try the fixed version you mentioned in comment 4, unluckily I cannot boot in fedora anymore due to another bug. But I managed to get a log as you requested before that happened.
I attach it here, might be useful. As soon as I manage to boot again in fedora it'll update it fully and test if it happens again.

Comment 6 Michele 2016-05-09 09:16:44 UTC
Created attachment 1155223 [details]
Log

Comment 7 Fedora Update System 2016-08-05 07:52:55 UTC
NetworkManager-1.2.4-1.fc24 network-manager-applet-1.2.4-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f739ece3cf

Comment 8 Fedora Update System 2016-08-05 21:21:37 UTC
NetworkManager-1.2.4-1.fc24, network-manager-applet-1.2.4-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f739ece3cf

Comment 9 Fedora Update System 2016-08-18 16:39:01 UTC
NetworkManager-1.2.4-2.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-fade485364

Comment 10 Fedora Update System 2016-08-19 00:56:50 UTC
NetworkManager-1.2.4-2.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-fade485364

Comment 11 Fedora Update System 2016-08-19 10:29:08 UTC
network-manager-applet-1.2.4-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f739ece3cf

Comment 12 Fedora Update System 2016-08-19 19:49:35 UTC
NetworkManager-1.2.4-2.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.