Bug 132423 - RPM xorg-x11-twm - Wrong dependency on X server
Summary: RPM xorg-x11-twm - Wrong dependency on X server
Status: CLOSED RAWHIDE
Alias: None
Product: Fedora
Classification: Fedora
Component: xorg-x11   
(Show other bugs)
Version: 2
Hardware: i586
OS: Linux
medium
medium
Target Milestone: ---
Assignee: X/OpenGL Maintenance List
QA Contact: David Lawrence
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-13 09:03 UTC by Benjamin Riefenstahl
Modified: 2007-11-30 22:10 UTC (History)
0 users

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-14 07:31:46 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Benjamin Riefenstahl 2004-09-13 09:03:17 UTC
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Macintosh; U; PPC Mac OS X; en) AppleWebKit/125.4 (KHTML, like Gecko) Safari/125.9

Description of problem:
The RPM for twm depends on the X server (xorg-x11).
Twm is an X client that can be used with any server, even
a non-local one, so this dependency is not warranted.

The situation creates problems for me, because the X
server has a whole bunch of other dependencies, so I
really don't want to install it.  I am using --nodeps with
the twm RPM right now, but that creates other problems,
e.g. it breaks aptnotify.

Version-Release number of selected component (if applicable):
xorg-x11-twm-6.7.0-2

How reproducible:
Always

Steps to Reproduce:
1.
2.
3.
    

Additional info:

Comment 1 Mike A. Harris 2004-09-14 07:31:46 UTC
* Tue Sep 14 2004 Mike A. Harris <mharris@redhat.com> 6.8.0-5
- Remove "Requires: %{name}, %{name}-libs = %{version}-%{release}"
from twm
  subpackage, as the libs twm is linked to should automatically be
picked up
  by rpm "find-provides", and xterm moved to a separate package a long
time
  ago, so both of these should no longer be needed. (#123423)






Note You need to log in before you can comment on or make changes to this bug.