Bug 1324946 - [Gtk+ 3.20] loads of warnings related to style changes in Gtk+ 3.20
Summary: [Gtk+ 3.20] loads of warnings related to style changes in Gtk+ 3.20
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libreoffice
Version: 24
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Caolan McNamara
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-07 16:35 UTC by Christian Stadelmann
Modified: 2016-04-11 09:12 UTC (History)
5 users (show)

Fixed In Version: libreoffice-5.1.2.1-4.fc24
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-04-11 09:12:07 UTC


Attachments (Terms of Use)

Description Christian Stadelmann 2016-04-07 16:35:11 UTC
Description of problem:
With 3.20, Gtk+ has removed GtkStyle and moved to GtkStyleContext. [1] [2]
Libreoffice-gtk3 is not yet adapted to these changes and thus has many Gtk-CRITICAL messages printed to console.

Version-Release number of selected component (if applicable):
libreoffice-5.1.2.1-3.fc24.x86_64

How reproducible:
always

Steps to Reproduce:
just open libreoffice, e.g. libreoffice-writer

Actual results:
Tens or hundreds of these error messages:

(soffice:5584): Gtk-CRITICAL **: gtk_style_context_restore: assertion 'GTK_IS_STYLE_CONTEXT (context)' failed
(soffice:5584): Gtk-CRITICAL **: gtk_style_context_save: assertion 'GTK_IS_STYLE_CONTEXT (context)' failed
(soffice:5584): Gtk-CRITICAL **: gtk_style_context_set_state: assertion 'GTK_IS_STYLE_CONTEXT (context)' failed
(soffice:5584): Gtk-CRITICAL **: gtk_render_background: assertion 'GTK_IS_STYLE_CONTEXT (context)' failed

Expected results:
No errors.

Additional info:

[1] https://developer.gnome.org/gtk3/stable/GtkStyle.html#GtkStyle.description
[2] https://git.gnome.org/browse/gtk+/tree/NEWS?h=gtk-3-20

Comment 1 Caolan McNamara 2016-04-08 10:52:29 UTC
The warning is fixed in libreoffice-5.1.2.1-4.fc24 which is building at the moment. The cause is not the GtkStyle/GtkStyleContext changes however.

Comment 2 Fedora Update System 2016-04-08 12:32:30 UTC
libreoffice-5.1.2.1-4.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-f5d31b630d

Comment 3 Fedora Update System 2016-04-09 18:52:51 UTC
libreoffice-5.1.2.1-4.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-f5d31b630d

Comment 4 Fedora Update System 2016-04-11 09:12:05 UTC
libreoffice-5.1.2.1-4.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.