Bug 132497 - Yum repositories won't upgrade about 30 xorg packages because it complains about missing xorg-6.7.0- libs
Summary: Yum repositories won't upgrade about 30 xorg packages because it complains ab...
Status: CLOSED WORKSFORME
Alias: None
Product: Fedora
Classification: Fedora
Component: yum (Show other bugs)
(Show other bugs)
Version: 2
Hardware: All Linux
medium
high
Target Milestone: ---
Assignee: Jeremy Katz
QA Contact:
URL:
Whiteboard:
Keywords:
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2004-09-14 04:19 UTC by Sam Williams
Modified: 2014-01-21 22:49 UTC (History)
2 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-07-29 18:15:27 UTC
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

Description Sam Williams 2004-09-14 04:19:37 UTC
Description of problem:
Yum provides the information on about 30 packages that need to be
upgraded for xorg, yet when you try to upgrade it complains after
downloading almost everything that it can not upgrade because
xorg-6.7.0-libs is unavailable. This condition has existed for months,
yet has not been resolved. I need X functioning in total and don't
know if there is something that wouldn't correct some of the issue I'm
currently having. The problem is being seen only on x86_64 hardware.


Version-Release number of selected component (if applicable):


How reproducible:
100%

Steps to Reproduce:
1. yum update
2. yum upgrade
3. error message
   
Actual results:
impossible to upgrade the xorg server code... continious errors, that
have persisted for the last three months.

Expected results:
find all necessary dependent packages and being allowed to upgraded.

Additional info:

Comment 1 Seth Vidal 2004-09-14 04:23:25 UTC
if you're running yum 2.1.X you can run:
yum --obsoletes update

and it should take care of it

if you're running yum 2.0.X you can run:
yum upgrade

and it should take care of it.

you're not the first person to encounter the problem but everyone has
gotten around it.

also - in future error reports please include actual output from yum.


Comment 2 Sam Williams 2004-09-15 02:31:17 UTC
Seth, te version of yum is 2.0.7. Performing an "upgrade" does not fix
the problem. It complains about an unsatisfied dependency with
xorg-6.7.0-libs, like I already reported. I will send the error
message and the output of both yum update, yum upgrade, and yum
--version. The machine is a dual opteron system at work.

Your solution did not work. There is a problem with the xorg files in
the repositories for x86_64. I will send the error message from work
tomorrow, but please investigate this. I'm not sure why you said
"upgrade" would fix the problem because the problem description
specifically said the error occurred during upgrade. Anyway please
objectively look at this problem and describe an appropriate solution.

Thanks for your help....

Comment 3 Seth Vidal 2004-09-15 21:53:28 UTC
I said that b/c for the 80 other people who have reported this problem
a yum upgrade has fixed it.

I also said that b/c for a shockingly large number of bug reports the
user asserts that they ran something when they've really not.



Comment 4 Seth Vidal 2004-10-08 14:44:14 UTC
Are you still seeing this problem? Do you still see it when using yum
2.1.5 or above?


Comment 5 Sam Williams 2004-10-15 03:51:29 UTC
yes... I just removed the exclude line today and got the following
output....

[root@thawk10]yum update Gathering header information file(s) from
server(s)
Server: Fedora Core 2 - x86_64 - Base
Server: Fedora Core 2 - x86_64 - Released Updates
Finding updated packages
Downloading needed headers
xorg-x11-tools-0-6.7.0-9. 100% |=========================|  72 kB    00:00
xorg-x11-0-6.7.0-9.x86_64 100% |=========================|  97 kB    00:00
xorg-x11-font-utils-0-6.7 100% |=========================|  70 kB    00:00
xorg-x11-base-fonts-0-6.7 100% |=========================|  83 kB    00:00
xorg-x11-ISO8859-14-75dpi 100% |=========================|  75 kB    00:00
xorg-x11-cyrillic-fonts-0 100% |=========================|  73 kB    00:00
xorg-x11-ISO8859-14-100dp 100% |=========================|  75 kB    00:00
xorg-x11-100dpi-fonts-0-6 100% |=========================|  81 kB    00:00
xorg-x11-sdk-0-6.7.0-9.x8 100% |=========================|  99 kB    00:00
xorg-x11-ISO8859-9-100dpi 100% |=========================|  75 kB    00:00
xorg-x11-ISO8859-2-100dpi 100% |=========================|  75 kB    00:00
xorg-x11-xdm-0-6.7.0-9.x8 100% |=========================|  71 kB    00:00
xorg-x11-75dpi-fonts-0-6. 100% |=========================|  81 kB    00:00
xorg-x11-ISO8859-2-75dpi- 100% |=========================|  75 kB    00:00
xorg-x11-syriac-fonts-0-6 100% |=========================|  70 kB    00:00
xorg-x11-xauth-0-6.7.0-9. 100% |=========================|  70 kB    00:00
xorg-x11-Xvfb-0-6.7.0-9.x 100% |=========================|  70 kB    00:00
xorg-x11-ISO8859-9-75dpi- 100% |=========================|  75 kB    00:00
xorg-x11-doc-0-6.7.0-9.x8 100% |=========================|  73 kB    00:00
xorg-x11-xfs-0-6.7.0-9.x8 100% |=========================|  71 kB    00:00
xorg-x11-ISO8859-15-75dpi 100% |=========================|  75 kB    00:00
xorg-x11-ISO8859-15-100dp 100% |=========================|  75 kB    00:01
xorg-x11-Xnest-0-6.7.0-9. 100% |=========================|  70 kB    00:00
xorg-x11-twm-0-6.7.0-9.x8 100% |=========================|  70 kB    00:00
xorg-x11-truetype-fonts-0 100% |=========================|  70 kB    00:00
xorg-x11-libs-data-0-6.7. 100% |=========================|  75 kB    00:00
xorg-x11-Mesa-libGLU-0-6. 100% |=========================|  70 kB    00:00
xorg-x11-devel-0-6.7.0-9. 100% |=========================| 134 kB    00:02
xorg-x11-libs-0-6.7.0-9.x 100% |=========================|  73 kB    00:00
xorg-x11-Mesa-libGL-0-6.7 100% |=========================|  70 kB    00:02
xorg-x11-Mesa-libGLU-0-6. 100% |=========================|  70 kB    00:00
xorg-x11-libs-0-6.7.0-9.i 100% |=========================|  73 kB    00:00
xorg-x11-Mesa-libGL-0-6.7 100% |=========================|  70 kB    00:00
xorg-x11-devel-0-6.7.0-9. 100% |=========================| 134 kB    00:00
Resolving dependencies
....Unable to satisfy dependencies
Package xorg-x11-libs needs xorg-x11-libs-data = 6.7.0-2, this is not
available.[root@thawk10]#

Comment 6 Seth Vidal 2004-10-15 03:54:58 UTC
And once more, for fun:

 yum upgrade 

what happens when you do that?



Comment 7 Matthew Miller 2005-04-26 16:32:45 UTC
Fedora Core 2 is now maintained by the Fedora Legacy project for
security updates only. If this problem is a security issue, please
reopen and reassign to the Fedora Legacy product. If it is not a
security issue and hasn't been resolved in the current FC3 updates or
in the FC4 test release, reopen and change the version to match.

Comment 8 Seth Vidal 2005-07-29 18:15:27 UTC
closing -> worksforme


Note You need to log in before you can comment on or make changes to this bug.