Bug 132506 - Overnight sessions don't expire
Overnight sessions don't expire
Status: CLOSED NOTABUG
Product: Fedora
Classification: Fedora
Component: php (Show other bugs)
2
All Linux
medium Severity medium
: ---
: ---
Assigned To: Joe Orton
David Lawrence
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-14 03:14 EDT by Niilo Kajander
Modified: 2007-11-30 17:10 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-14 04:44:16 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Niilo Kajander 2004-09-14 03:14:59 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7)
Gecko/20040807 Firefox/0.9.3

Description of problem:
I'm not quite sure if this is an upstream bug or a bug at all but:
If a php session is opened and it is kept alive beyond 12PM it never
expires.

Version-Release number of selected component (if applicable):
php-4.3.8-2.1

How reproducible:
Always

Steps to Reproduce:
1. Create a new php session
2. Keep it alive until the next day starts and leave it be for the night
3. Do something within the session
    

Actual Results:  Session is still alive

Expected Results:  Session should have expired in the morning

Additional info:

The session-related lines of /etc/php.ini:

session.save_handler = files
session.save_path = /var/lib/php/session
session.use_cookies = 1
session.name = PHPSESSID
session.auto_start = 0
session.cookie_lifetime = 0
session.cookie_path = /
session.cookie_domain =
session.serialize_handler = php
session.gc_probability = 1
session.gc_divisor     = 1000
session.gc_maxlifetime = 3600
session.bug_compat_42 = 0
session.bug_compat_warn = 1
session.referer_check =
session.entropy_length = 0
session.entropy_file =
session.cache_limiter = nocache
session.cache_expire = 180
session.use_trans_sid = 0
Comment 1 Joe Orton 2004-09-14 04:10:42 EDT
Thanks for the report.  I can't see anything obviously wrong with the
code which could cause this.

You realise that the session garbage collector is run only when a new
session is started? (i.e. if no new sessions are being started on your
server, no old sessions will get expired)
Comment 2 Niilo Kajander 2004-09-14 04:44:16 EDT
Oh boy, looks like it's a bug in our web application. Our coder hasn't
used anything similar to time(2) but a simple HH:MM format timestamp
for the sessions *g*..ENOTENOUGHCOFFEE

Sorry for the inconvenience and keep up the good work (:

Note You need to log in before you can comment on or make changes to this bug.