Bug 132531 - RPM Pre-Dependency for redhat-artwork is wrong
RPM Pre-Dependency for redhat-artwork is wrong
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Linux 3
Classification: Red Hat
Component: redhat-artwork (Show other bugs)
3.0
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Alexander Larsson
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-14 11:04 EDT by Christian Rohrmeier
Modified: 2007-11-30 17:07 EST (History)
0 users

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-14 16:57:55 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Christian Rohrmeier 2004-09-14 11:04:43 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (Windows; U; Windows NT 5.1; en-US; rv:1.7)
Gecko/20040707 Firefox/0.8

Description of problem:

RPM Pre-Dependency for redhat-artwork is wrong:

rpm -qpR redhat-artwork-0.73.2-1E.i386.rpm
redhat-logos >= 1.1.10
/usr/lib/qt-3.1
rpmlib(PayloadFilesHavePrefix) <= 4.0-1
rpmlib(CompressedFileNames) <= 3.0.4-1

As can be seen one of the Pre-Depends is "/usr/lib/qt-3.1". This is
not an installable package. Versioning information is also missing.


Version-Release number of selected component (if applicable):
redhat-artwork-0.73.2-1E.i386.rpm

How reproducible:
Always

Steps to Reproduce:
1.rpm -qpR redhat-artwork-0.73.2-1E.i386.rpm
2.
3.
    

Expected Results:  The Pre-depends should be specified with the
correct package name of QT (i.e. "qt") and versioning.

Additional info:
Comment 1 Suzanne Hillman 2004-09-14 16:57:55 EDT
That's how the rpm dependancies work. For more information on RPM,
please see the <a href="http://www.rpm.org/max-rpm/">Maximum RPM</a> book.
Comment 2 Christian Rohrmeier 2004-09-15 03:32:59 EDT
[root@bes201 bin]# apt-get install redhat-artwork
Reading Package Lists... Done
Building Dependency Tree... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.

Since you only requested a single operation it is extremely likely 
that the package is simply not installable and a bug report against
that package should be filed.
The following information may help to resolve the situation:

The following packages have unmet dependencies:
  redhat-artwork: PreDepends: /usr/lib/qt-3.1 but it is not 
installable
E: Broken packages


[root@bes201 bin]# apt-cache show qt
Package: qt
Section: System Environment/Libraries
Installed Size: 6885
Maintainer: Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Version: 1:3.1.2-13.4
Pre-Depends: /bin/sh, /bin/sh, /sbin/ldconfig, fileutils, rpmlib
(CompressedFileNames) (<= 3.0.4-1), rpmlib(PayloadFilesHavePrefix) 
(<= 4.0-1)
Depends: /bin/sh, fontconfig (>= 2.0), libGL.so.1, libGLU.so.1, 
libICE.so.6, libSM.so.6, libX11.so.6, libXext.so.6, libXft.so.2, 
libXmu.so.6, libXrandr.so.2, libXrender.so.1, libc.so.6, libc.so.6
(GLIBC_2.0), libc.so.6(GLIBC_2.1), libc.so.6(GLIBC_2.1.2), libc.so.6
(GLIBC_2.1.3), libc.so.6(GLIBC_2.2), libc.so.6(GLIBC_2.3), 
libdl.so.2, libdl.so.2(GLIBC_2.0), libdl.so.2(GLIBC_2.1), 
libfontconfig.so.1, libfreetype.so.6, libgcc_s.so.1, libgcc_s.so.1
(GLIBC_2.0), libjpeg.so.62, libm.so.6, libm.so.6(GLIBC_2.0), 
libmng.so.1, libpng12.so.0, libpthread.so.0, libpthread.so.0
(GLIBC_2.0), libpthread.so.0(GLIBC_2.1), libpthread.so.0(GLIBC_2.2), 
libpthread.so.0(GLIBC_2.3.2), libqt-mt.so.3, libstdc++.so.5, 
libstdc++.so.5(CXXABI_1.2), libstdc++.so.5(GLIBCPP_3.2), libz.so.1
Conflicts: qt2 (< 2.3.1-1)
Provides: libqt-mt.so.3, libqui.so.1, qt (= 1:3.1.2-13.4)
Obsoletes: qt-Xt, qt3
Architecture: i386
Size: 2761163
MD5Sum: 171e31325a6974fe6b3161b0dd935e05
Filename: qt-3.1.2-13.4.i386.rpm
Description: The shared library for the Qt GUI toolkit.
 Qt is a GUI software toolkit which simplifies the task of writing and
 maintaining GUI (Graphical User Interface) applications
 for the X Window System.

 Qt is written in C++ and is fully object-oriented.

 This package contains the shared library needed to run qt
 applications, as well as the README files for qt.


[root@bes201 bin]# apt-get install qt
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  XFree86-Mesa-libGLU libmng
The following NEW packages will be installed:
  XFree86-Mesa-libGLU libmng qt
0 upgraded, 3 newly installed, 0 removed and 64 not upgraded.
Need to get 3258kB of archives.
After unpacking 7663kB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://... redhat/rhel3/ws/os XFree86-Mesa-libGLU 4.3.0-68.EL 
[393kB]
Get:2 http://... redhat/rhel3/ws/os libmng 1.0.4-3 [104kB]
Get:3 http://... redhat/rhel3/ws/os qt 1:3.1.2-13.4 [2761kB]
Fetched 3258kB in 0s (11.5MB/s)
warning: /var/cache/apt/archives/XFree86-Mesa-libGLU_4.3.0-
68.EL_i386.rpm: V3 DSA signature: NOKEY, key ID db42a60e
Committing changes...
Preparing...                
########################################### [100%]
   1:qt                     
########################################### [ 33%]
   2:XFree86-Mesa-libGLU    
########################################### [ 67%]
   3:libmng                 
########################################### [100%]
Done.

[root@bes201 bin]# apt-get install redhat-artwork
Reading Package Lists... Done
Building Dependency Tree... Done
The following extra packages will be installed:
  redhat-logos
The following NEW packages will be installed:
  redhat-artwork redhat-logos
0 upgraded, 2 newly installed, 0 removed and 64 not upgraded.
Need to get 8788kB of archives.
After unpacking 10.8MB of additional disk space will be used.
Do you want to continue? [Y/n] y
Get:1 http://... redhat/rhel3/ws/os redhat-logos 1.1.14.3-1 [860kB]
Get:2 http://... redhat/rhel3/ws/os redhat-artwork 0.73.2-1E [7928kB]
Fetched 8788kB in 0s (11.7MB/s)
warning: /var/cache/apt/archives/redhat-logos_1.1.14.3-1_noarch.rpm: 
V3 DSA signature: NOKEY, key ID db42a60e
Committing changes...
Preparing...                
########################################### [100%]
   1:redhat-artwork         
########################################### [ 50%]
   2:redhat-logos           
########################################### [100%]
Done.
[root@bes201 bin]#
Comment 3 Alexander Larsson 2004-09-15 03:44:06 EDT
It appears as if apt-get doesn't support all types of rpm dependencies
then. You better bring that up with the apt-get-rpm developers.

Note You need to log in before you can comment on or make changes to this bug.