Bug 1325472 - pkg-config file has a typo
Summary: pkg-config file has a typo
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: spandsp
Version: 25
Hardware: Unspecified
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Igor Gnatenko
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard:
: 1376056 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2016-04-09 01:29 UTC by Nirbheek Chauhan
Modified: 2016-12-07 05:24 UTC (History)
4 users (show)

Fixed In Version: spandsp-0.0.6-1.fc24 spandsp-0.0.6-1.fc25
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2016-12-03 10:57:03 UTC
Type: Bug


Attachments (Terms of Use)

Description Nirbheek Chauhan 2016-04-09 01:29:21 UTC
spandsp.pc has a typo in the libdir variable. It says:

  libdir=$(exec_prefix)/lib64

instead of 

  libdir=${exec_prefix}/lib64

The former doesn't work since pkg-config only understands ${} syntax. It works by chance while using spandsp as a dependency in an autotools-based build system because autotools will expand it to the currently-configured exec_prefix value.

The fix is obvious. :)

Thanks!

Comment 1 Jan Kurik 2016-07-26 04:23:37 UTC
This bug appears to have been reported against 'rawhide' during the Fedora 25 development cycle.
Changing version to '25'.

Comment 2 Jan-Michael Brummer 2016-11-26 19:44:51 UTC
Please fix this trivial issue as it affects my project as well.

Comment 3 Igor Gnatenko 2016-11-28 11:38:08 UTC
*** Bug 1376056 has been marked as a duplicate of this bug. ***

Comment 4 Fedora Update System 2016-11-28 12:51:57 UTC
spandsp-0.0.6-1.fc25 has been submitted as an update to Fedora 25. https://bodhi.fedoraproject.org/updates/FEDORA-2016-d4f8e155e1

Comment 5 Fedora Update System 2016-11-28 12:52:07 UTC
spandsp-0.0.6-1.fc24 has been submitted as an update to Fedora 24. https://bodhi.fedoraproject.org/updates/FEDORA-2016-1eb3513982

Comment 6 Fedora Update System 2016-12-02 06:26:39 UTC
spandsp-0.0.6-1.fc24 has been pushed to the Fedora 24 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-1eb3513982

Comment 7 Fedora Update System 2016-12-02 18:53:53 UTC
spandsp-0.0.6-1.fc25 has been pushed to the Fedora 25 testing repository. If problems still persist, please make note of it in this bug report.
See https://fedoraproject.org/wiki/QA:Updates_Testing for
instructions on how to install test updates.
You can provide feedback for this update here: https://bodhi.fedoraproject.org/updates/FEDORA-2016-d4f8e155e1

Comment 8 Fedora Update System 2016-12-03 10:57:03 UTC
spandsp-0.0.6-1.fc24 has been pushed to the Fedora 24 stable repository. If problems still persist, please make note of it in this bug report.

Comment 9 Fedora Update System 2016-12-07 05:24:24 UTC
spandsp-0.0.6-1.fc25 has been pushed to the Fedora 25 stable repository. If problems still persist, please make note of it in this bug report.


Note You need to log in before you can comment on or make changes to this bug.