Bug 132585 - hdc: dma_timer_expiry: dma status == 0x21
hdc: dma_timer_expiry: dma status == 0x21
Status: CLOSED DUPLICATE of bug 132584
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
2
i686 Linux
medium Severity medium
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-09-14 16:22 EDT by David Kaplan
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:05:38 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Kaplan 2004-09-14 16:22:26 EDT
Description of problem:
I am using FC2 on a Dell Inspiron 1150 and have all sorts of DMA
timeouts that make the hard drive very slow.  I could try turning off
DMA, but that appears to really slow things down.  I have seen other
DMA type bugs and they all appear related, but no two appear to be
exactly the same.

What I really want to know is what is this doing to my hard drive? 
Should I turn DMA off?  

Version-Release number of selected component (if applicable):
FC2 with all the updates

How reproducible:
Always

Steps to Reproduce:
1. Save a big enough file to notice
2.
3.
  
Actual results:
DMA Timeouts.  dmesg output below

Expected results:
No DMA timeouts

Additional info:

hdc: dma_timer_expiry: dma status == 0x21
hdc: DMA timeout error
hdc: dma timeout error: status=0xd0 { Busy }
 
hdc: DMA disabled
ide1: reset: success
Losing some ticks... checking if CPU frequency changed.
hdc: DMA disabled
Losing some ticks... checking if CPU frequency changed.
Losing some ticks... checking if CPU frequency changed.
Losing some ticks... checking if CPU frequency changed.
Losing too many ticks!
TSC cannot be used as a timesource.
Possible reasons for this are:
  You're running with Speedstep,
  You don't have DMA enabled for your hard disk (see hdparm),
  Incorrect TSC synchronization on an SMP system (see dmesg).
Falling back to a sane timesource now.
hdc: dma_timer_expiry: dma status == 0x21
hdc: DMA timeout error
hdc: dma timeout error: status=0xd0 { Busy }
 
hdc: DMA disabled
ide1: reset: success
Comment 1 Bill Nottingham 2004-09-14 22:32:52 EDT

*** This bug has been marked as a duplicate of 132584 ***
Comment 2 Red Hat Bugzilla 2006-02-21 14:05:38 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.